JS shell has no facilities for testing JSExternalString

RESOLVED DUPLICATE of bug 1330593

Status

()

RESOLVED DUPLICATE of bug 1330593
4 years ago
a year ago

People

(Reporter: jimb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
There's no way to generate a JSExternalString in the JavaScript shell. This would allow us to more thoroughly test work like that in bug 1144371 (tools for dumping string representations) and bug 1063257 (primitives to return byte size of strings).
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1330593
You need to log in before you can comment on or make changes to this bug.