Closed Bug 1145496 Opened 5 years ago Closed 5 years ago

Image does not render completely. And Reload(F5, Ctrl+F5) makes completely black and loading forever.

Categories

(Core :: ImageLib, defect)

37 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox36 --- unaffected
firefox37 --- affected
firefox38 --- affected
firefox39 --- affected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [dupeme] [gfx-noted])

Attachments

(1 file)

Attached image haenau-O2.gif
[Tracking Requested - why for this release]: Regression since Firefox36

Steps to reproduce:
1. Open attached

Actual results:
Image does not render completely.
And Reload(F5, Ctrl+F5) does not help, it makes completely black and loading forever

Expected results:
Image should be fully render.
And also Reload(F5, Ctrl+F5) should work properly


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=da5084c9e3e6&tochange=6e4dce410c27

Regressed by Bug 1116716 or Bug 1116719
Seth - Can you please take a look at this regression?

Is this specifically an issue with GIFs with large file sizes?
Flags: needinfo?(seth)
Whiteboard: [dupeme] → [dupeme] [gfx-noted]
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #1)
> Seth - Can you please take a look at this regression?
> 
> Is this specifically an issue with GIFs with large file sizes?

It sounds to me a lot like we're just running into memory limits, yeah. I'll investigate to verify that.
Flags: needinfo?(seth)
Yep, this image ends up taking well over a gigabyte of memory to decode.

Sorry, but this is not going to be supported. There are drastically more efficient ways to encode this image.

The refresh behavior just happens because the image is cached, and is marked as "bad" because it hit the memory limit. That's also a WONTFIX.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.