Bangla MN font rendered incorrectly

RESOLVED DUPLICATE of bug 686225

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 686225
3 years ago
3 years ago

People

(Reporter: Ryusei Yamaguchi, Unassigned)

Tracking

36 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8580544 [details]
Screenshot of আদিত্য চোপড়া - Wikipedia

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Open this page: http://bn.wikipedia.org/wiki/%E0%A6%86%E0%A6%A6%E0%A6%BF%E0%A6%A4%E0%A7%8D%E0%A6%AF_%E0%A6%9A%E0%A7%8B%E0%A6%AA%E0%A6%A1%E0%A6%BC%E0%A6%BE


Actual results:

The combining character sequence “চো” in Bangla MN doesn't rendered correctly.
“চো” in Noto Sans Bengali is correct. it is below of the page.


Expected results:

“চো” in Bangla MN is rendered as in Noto Sans Bengali.

Comment 1

3 years ago
Created attachment 8580565 [details]
Screenshot from Firefox 36 on Fedora 21

Why is this a problem in Firefox itself and not with your installed fonts or webfonts delivered? No problems on Fedora 21, see screenshot.
Component: Untriaged → Layout: Text
Product: Firefox → Core
This is a longstanding bug with Firefox rendering certain Indic AAT fonts; see bug 686225.

(It's really a font bug, though it doesn't show up in all circumstances, depending on the font features used by the application -- unfortunately, the way Gecko manages font shaping causes it to hit this bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686225
You need to log in before you can comment on or make changes to this bug.