Theme switcher panel and Show/hide menus in customization mode are mispositioned

RESOLVED DUPLICATE of bug 1145868

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1145868
3 years ago
3 years ago

People

(Reporter: Ge3k0s, Unassigned)

Tracking

({regression})

39 Branch
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox38 unaffected)

Details

(Reporter)

Description

3 years ago
Since a few days on Nightly the theme switcher panel in customization mode doesn't anchor to the button anymore but far above. Same for the show/hide menu that appears in the middle of the screen.
(Reporter)

Updated

3 years ago
Component: Theme → Toolbars and Customization

Comment 1

3 years ago
Sounds like it's caused by bug 1143974. :tn?
Blocks: 1143974
Flags: needinfo?(tnikkel)
Keywords: regression, regressionwindow-wanted

Comment 2

3 years ago
[Tracking Requested - why for this release]:

Regression range:
good=2015-03-15
bad=2015-03-16
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=af68c9c0e903&tochange=436686833af0

suspected: 
Timothy Nikkel — Bug 1130400. Part 1. Pass the passed in anchor frame to SetPopupPosition in nsMenuPopupFrame::LayoutPopup if we have one. r=enndeakin
Blocks: 1130400
No longer blocks: 1143974
status-firefox38: --- → unaffected
tracking-firefox39: --- → ?
Keywords: regressionwindow-wanted
Version: Trunk → 39 Branch

Updated

3 years ago
Duplicate of this bug: 1145107
Keywords: regressionwindow-wanted
Keywords: regressionwindow-wanted
I'll investigate. If I can't fix it shortly I'll back out.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hmm, so my local bisection blames https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=6cd4d71818ee

However applying part 2 of bug 1130400 fixes the bug for me. This does make sense since a change on reflow of flex items could determine if the condition of bug 1130400 comes up or not.

Part 2 of bug 1130400 is already on inbound, so this bug should get fixed when that merges.

Comment 6

3 years ago
(In reply to Timothy Nikkel (:tn) from comment #5)
> Hmm, so my local bisection blames
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?changeset=6cd4d71818ee


It was a speculative guess of mine, so maybe I was wrong.

Comment 7

3 years ago
Sorry dupe
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145868
No longer blocks: 1130400
Flags: needinfo?(tnikkel)
tracking-firefox39: ? → ---
You need to log in before you can comment on or make changes to this bug.