[RTL][Contacts]The alphabet picker is located on the left side of Gmail, Outlook and Facebook contacts list view.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: arcturus)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

[1.Description]:
[RTL][v2.2&v3.0][Contacts]Sign in Gmail, Outlook and Facebook accounts in Contacts app, the alphabet picker is located on the left side of contacts list view.
See attachment:Screenshot_Contact list.png

[2.Testing Steps]: 
1.Launch Contacts.
2.Enter Settings view.
3.Import contacts from Gmail, Outlook and Facebook.
4.Sign in Gmail, Outlook and Facebook accounts.
5.Observe the contact list.

[3.Expected Result]: 
5.The alphabet picker should be located on the right side of contacts list view.

[4.Actual Result]: 
5.The alphabet picker is located on the left side of contacts list view.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,10/10

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Correct, the alphabet picker should be on the right side, as in Bug 1135927
Nominating to ensure consistency across Contacts app
blocking-b2g: --- → 2.2?
Priority: -- → P2
triage: major issue on RTL
blocking-b2g: 2.2? → 2.2+
This is a blocking bug, we are 1 week away from FC, and no one has been assigned to this yet.
Can we please have someone from Contacts team take this? Julien maybe you can help with getting the word out please? I've reached out to EM but no reply yet - must be busy
thanks! :)
Flags: needinfo?(felash)
This is weird, given the screenshots in bug 1135927, that this works like this.

This is more a question to Francisco.
Flags: needinfo?(felash) → needinfo?(francisco)
Hi Julien, you mean the alphabet is on the left?

That's correct, should be on the right, that means not mirroring LTR behaviour. Right now in the normal list we have it working correctly, this is for the list that appears when you import from gmail, live, etc.
Flags: needinfo?(francisco)
Comment on attachment 8586385 [details] [review]
[gaia] arcturus:bug-1145543 > mozilla-b2g:master

Finally went through the quick and dirty solution that is having the specific rules for the import page.

Ideally, I would like to have a single list component, shareable under all apps that need a contact list (with a specific source), but we don't have time for that :(
Attachment #8586385 - Flags: review?(ferjmoreno)
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Attachment #8586385 - Flags: review?(ferjmoreno) → review+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
According to the comment 0, this issue has been verified pass on latest Flame 3.0 build.
See attachment:Verify1_Flame3.0_Pass.png
Reproducing rate:0/10

Flame 3.0 build (Unaffected):
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Please nominate this patch for Gaia v2.2 approval when you get a chance.
Target Milestone: --- → 2.2 S9 (3apr)
Flags: needinfo?(francisco)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15413/
Flags: in-moztrap+
Whiteboard: MGSEI-RTL-3F
Comment on attachment 8586385 [details] [review]
[gaia] arcturus:bug-1145543 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL
[User impact] if declined:
Bad user experience
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
Flags: needinfo?(francisco)
Attachment #8586385 - Flags: approval-gaia-v2.2?
Attachment #8586385 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Posted image v2.2_pass.png
This issue has been verified passed on latest build of Flame 2.2 with the same steps in comment 0.
See attachment:v2.2_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F
You need to log in before you can comment on or make changes to this bug.