Closed Bug 1145551 Opened 5 years ago Closed 5 years ago

DTMF should be sent using the active SIM, the given or the default one (in that order)

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: fan.luo, Assigned: ferjm)

References

Details

Attachments

(6 files)

Attached video 10000.mp4
[1.Description]:
[Flame v2.2 & v3.0][Contacts]Extension will not be sent if user select a non default SIM.
Found time:17:29
Attachment:logcat_1729 & 10000.MP4

[2.Testing Steps]: 
Prerequisite:Device with 2 SIM cards.
1. Save a number in Contacts as "10000,,,1".
2. Open contact details. 
3. Long tap on Dial to choose non default SIM. 

[3.Expected Result]: 
3.Outgoing call made, extension sent without user interaction after a longer pause. 

[4.Actual Result]: 
3.Outgoing call made, but extension not be sent.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15691

[8.Note]:
Also exist on dialer
Attached file logcat_1729.txt
[Blocking Requested - why for this release]: Broken feature planned for 2.2.

QA wanted to get a logcat with RIL debugging enabled[1]

[1] https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#RIL_Debugging
Blocks: 911055
blocking-b2g: --- → 2.2?
Keywords: qawanted
QA Contact: bzumwalt
Unable to get contact with an extension to work at all regardless of SIM that used. Created a contact "6509030800,,,92" and the extension is never sent when I initiate call through contacts no matter if I use SIM 1 or SIM 2. Want to make sure I am not missing a step here.


Device: Flame 3.0
Build ID: 20150320010204
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Flags: needinfo?(ktucker)
Flags: needinfo?(jlorenzo)
I repro the issue with the SIM1 on yesterday's 2.2 build[1]. Beatriz, can you confirm this is a regression?

[1] Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jlorenzo) → needinfo?(beatriz.rodriguezgomez)
Flags: needinfo?(ktucker)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #2)
> [Blocking Requested - why for this release]: Broken feature planned for 2.2.
> 
> QA wanted to get a logcat with RIL debugging enabled[1]
> 
> [1] https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#RIL_Debugging

Hi Johan,

Update the logcat (new_logcat_v2.2_1538.txt) with RIL debugging enabled[1].
Keywords: qawanted
Please see "new_logcat_v2.2_1553.txt". 
Please ignore "new_logcat_v2.2_1538.txt".Thanks.
I have tested with Flame:
*Today 2.2 build(Gecko-c36e800.Gaia-44c6206)
*20th January build v2.2 (Gecko-bb6c4d3.Gaia-f5b3d1b)

With the same result described in this bug:

When the call is done through the SIM card that it is not active by default, the pause (extensions) are not done while it is working very well in the default SIM card.

I am not sure if this functionality was covered by the first implementation of the dial pause feature. I dont think so. German could you please confirm?
Flags: needinfo?(beatriz.rodriguezgomez) → needinfo?(gtorodelvalle)
Hi guys! Sadly I think we did not cover the mentioned use case in the current implementation and probably the comma separated part is being lost (probably sanitised) somewhere :(
Flags: needinfo?(gtorodelvalle)
QA Whiteboard: [MGSEI-Triage+]
triage: major issue on new feature. currently it's an inconsistent behavior
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → ferjmoreno
Depends on: 1145079
Component: Gaia::Contacts → Gaia::Dialer
This might be a RIL issues. I can see this entry in the log when trying to send a DTMF with a non default SIM:

2771 Gecko  I  RIL Worker: [0] Handling parcel as REQUEST_DTMF_START
2771 Gecko  I  -*- RadioInterface[0]: Received message from worker: {"dtmfChar":"7","rilMessageClientId":0,"rilMessageToken":64,"rilMessageType":"startTone","rilRequestType":49,"rilRequestError":2,"errorMsg":"GenericFailure","success":false}
Component: Gaia::Dialer → RIL
Attached file Gaia fix
Attachment #8583087 - Attachment description: [gaia] ferjm:bug1145551.dtmf.dsds > mozilla-b2g:master → Gaia fix
Attached patch Gecko fixSplinter Review
Hsin-Yi, while we can fix this issue on Gaia only by giving the appropriate service ID to Telephony::SendTone, I also think that we need to fix this in the platform by selecting the active service ID instead of the default one if there is a call in place. If you think that this approach is ok, I'll write some tests for it. Thanks in advance for your feedback!
Attachment #8583091 - Flags: feedback?(htsai)
Attachment #8583087 - Flags: review?(drs)
Comment on attachment 8583087 [details] [review]
Gaia fix

Looks good.
Attachment #8583087 - Flags: review?(drs) → review+
Thank you Doug!
Component: RIL → Gaia::Dialer
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#wf143K9CRRi-Yly0V0GOZg

The pull request failed to pass integration tests. It could not be landed, please try again.
Comment on attachment 8583091 [details] [diff] [review]
Gecko fix

Review of attachment 8583091 [details] [diff] [review]:
-----------------------------------------------------------------

This does make sense to me. Thank you!

Just a note that we will encounter some issues in DSDA if gaia doesn't apply the serviceId, but for DSDS that's fine.
Attachment #8583091 - Flags: feedback?(htsai) → feedback+
Summary: [Flame][Contacts]Device can't sent extension via sim2. → DTMF should be sent using the active SIM, the given or the default one (in that order)
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(ferjmoreno)
Target Milestone: --- → 2.2 S9 (3apr)
Flags: needinfo?(ferjmoreno)
See Also: → 1148036
Comment on attachment 8583087 [details] [review]
Gaia fix

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Dialer/RIL
[User impact] if declined: The user won't be able to send dial tones while with a non-default SIM card.
[Testing completed]: Manual tests. Unit test added.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8583087 - Flags: approval-gaia-v2.2?
I filed bug 1148036 for the platform change.
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0. 

Actual result: Device enters outgoing call made, and DTMF is sent using the active SIM1/SIM2.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/5

Device: Flame 3.0 build(Pass)
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 19:26:42 EDT 2015
Bootloader             L1TC000118D0
Attachment #8583087 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2. 

Actual result: Device enters outgoing call made, and DTMF is sent using the active SIM1/SIM2.
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.