[Flame][Camera] Video recording would not stop instantly when coming a call .

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Camera
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: Elie, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [MGSEI-v2.2-2R][priority] 2.6UXnom)

Attachments

(2 attachments)

1.88 MB, video/mp4
Details
1.86 MB, text/plain
Details
(Reporter)

Description

3 years ago
[1.Description]:
[Flame][v2.2&3.0][Camera]Call firefox device when recording video,the video will not stop immediately,the coming call ringtone will be recorded to video.
Attchment:video1_clip.mp4 and log.txt
Happen time:8:14

[2.Testing Steps]: 
 1.Launch camera;
 2.Switch to camcorder;
 3.Start recording video;
 4.Coming a call to device.

[3.Expected Result]: 
5.Video recording can stop instantly. When previewing video, you can‘t hear ringtone of call .

[4.Actual Result]: 
4.Video recording can't stop instantly.When previewing video,you can hear ringtone of call .

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
13274
(Reporter)

Comment 1

3 years ago
Created attachment 8580629 [details]
video1_clip.mp4
(Reporter)

Comment 2

3 years ago
Created attachment 8580630 [details]
log.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected

Comment 3

3 years ago
Hi, Elie,

This seems to be a legacy bug.
Can it be reproducted on v2.1?
Flags: needinfo?(zikui.yang)
See Also: → bug 951744
(Reporter)

Comment 4

3 years ago
(In reply to William Hsu [:whsu] from comment #3)
> Hi, Elie,
> 
> This seems to be a legacy bug.
> Can it be reproducted on v2.1?

Hi William. This issue exists on flame 2.1
Flame 2.1:
Build ID               20150402161201
Gaia Revision          4e7d880defb83c25b49462479c02b3e64d21f421
Gaia Date              2015-04-02 18:26:54
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/e76f5e7a264d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.194043
Firmware Date          Thu Apr  2 19:40:52 EDT 2015
Bootloader             L1TC000118D0
Reproduce rate         5/5
status-b2g-v2.1: --- → affected
Flags: needinfo?(zikui.yang) → needinfo?(whsu)

Comment 5

3 years ago
This bug existed on FxOS for a long time.
It is not a critical bug but I suggest to fix it on latest branch.

Many thanks.
Flags: needinfo?(whsu)
The correct solution to this issue has been discussed in some other bugs (which I can't find right now). At least one suggestion was that the ringer should be silenced while video is being recorded, so that the recording doesn't interrupt the video if the user chooses not to answer the call.
Flags: needinfo?(tshakespeare)
Huzzah! I have found the bug (I think) that Mike is talking about!

https://bugzilla.mozilla.org/show_bug.cgi?id=995372
Comment 6 sums up all the issues around recording and call quite nicely, if I say so myself... :)
Flags: needinfo?(tshakespeare)
Whiteboard: [MGSEI-v2.2-2R]

Updated

3 years ago
Duplicate of this bug: 1130966
[Tracking Requested - why for this release]:
aosmond, any chance this bug will be fixed for 2.5?
Flags: needinfo?(aosmond)
[Blocking Requested - why for this release]:

This is a poor user experience if videos record the incoming call's ringtone - sending it to the triage committee to decide whether it is a blocker, but personally this would be quite annoying, since some people do use phone to take important footages
blocking-b2g: --- → 2.5?
Flags: needinfo?(aosmond)

Comment 11

3 years ago
Triage on 8/19: Adding to priority bugs to fix (Andrew: see comment 6 for suggested fix) and not blocking
blocking-b2g: 2.5? → ---
Flags: needinfo?(aosmond)
Whiteboard: [MGSEI-v2.2-2R] → [MGSEI-v2.2-2R][priority]
Whiteboard: [MGSEI-v2.2-2R][priority] → [MGSEI-v2.2-2R][priority] 2.6UXnom
Flags: needinfo?(aosmond)

Comment 12

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.