Closed Bug 1145608 Opened 8 years ago Closed 7 years ago

Firefox makes too many requests when playing this video

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1196398

People

(Reporter: jrmuizel, Unassigned)

Details

http://mirror.as35701.net/video.fosdem.org//2015/devroom-mozilla/ud2218a_superturbocharging_firefoxos_app_development__CAM_ONLY.mp4?_=1

If you look in the network panel of dev tools you'll see lots of Partial content requests.


Chrome has only 3 or 4
Came across this while searching for duplicates..

The link is 404, is this the right one - http://video.fosdem.org/2015/devroom-mozilla/superturbocharging_firefoxos_app_development__CAM_ONLY.mp4 ?

FWIW, with the new link I get 10 requests, then the video starts playing normally.

see also bug 1142084 and bug 1142455.
Firefox sends >100 requests for me. It's definitely a bug with Firefox introduced sometime in early 2015.

If you remove the audio stream from the mp4, it will work. So it is a bug. See:
https://bugzilla.mozilla.org/show_bug.cgi?id=1142455
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196398
You need to log in before you can comment on or make changes to this bug.