If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

NOWRAP attribute doesn't work if cell's width not enough

RESOLVED INVALID

Status

()

Core
Layout: Tables
P5
trivial
RESOLVED INVALID
16 years ago
15 years ago

People

(Reporter: Pete Zha, Assigned: Alexandru Savulov)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl][p3])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2
BuildID:    2001112114

If the width not big enough, NOWRAP attribute does not work.


Reproducible: Always
Steps to Reproduce:
Just open the first attachment
See three tables. The second tables's width is 1. So word in this table is
wrapped although the NOWRAP attribute exist.

I wonder that if there was a rule to disable NOWRAP attribute if the cell's
width is not wide enough...
(Reporter)

Comment 1

16 years ago
Created attachment 61218 [details]
Test case of NOWRAP attribute

Add test case of this bug
Not a DOM problem, over to HTMLTables.
Assignee: jst → karnaze
Component: DOM HTML → HTMLTables
QA Contact: stummala → amar
(Reporter)

Comment 3

16 years ago
Add CC to browser-china@sun.com
QA Contact: amar → stummala

Comment 4

16 years ago
great testcase. confirming bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [awd:tbl][p3]

Updated

16 years ago
Target Milestone: --- → Future

Comment 5

16 years ago
changing priority to P5
Priority: -- → P5

Comment 6

16 years ago
If this is trivial then I would like to know what a trivial workaround for this
bug is.

Maybe there is a stylesheet trick to fix this?

Honestly I am struggling to lay out a page where I want to guarantee that the
table cell content is in one line.

At the same time, I do not want the table cell to be wider than the width of the
line.

Only Internet Explorer 3 had this problem. I think contemporary browsers should
not really have this bug. Why is this "future" ?? Ouch!

Comment 7

16 years ago
I see why it is considered trivial. There is an easy workaround:

Do not code the width parameter. Control width by requesting more
width than available in other columns.

Comment 8

16 years ago
->alexsavulov.
Assignee: karnaze → alexsavulov

Comment 9

15 years ago
In my opinion, this is not a bug. It all comes down to which attribute should
have precedense, WIDTH or NOWRAP. All other browser I have tested also tries to
honor the WIDTH rather than NOWRAP (IE6, Opera6, Nav4.7 and Nav3.04.)

Recommending INVALID (not a bug), 2002-07-06-04 trunk win98.
(Reporter)

Comment 10

15 years ago
I think we need to make sure which attribute is in higher priority. WIDTH or NOWRAP?
http://www.w3.org/TR/REC-html40/struct/tables.html
[When present, this boolean attribute tells visual user agents to disable
automatic text wrapping for this cell.] Not very clear, and this attribute seems
to be Deprecated now.
I agree to close this one.
(Reporter)

Comment 11

15 years ago
Look this, this is how IE understand NOWRAP.
http://msdn.microsoft.com/workshop/author/dhtml/reference/properties/nowrap.asp
Mozilla, IE6, Opera6, Nav4.7 and Nav3.04 have the same behaviour here.
Not a bug. Reporter agrees.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.