Closed Bug 1145756 Opened 5 years ago Closed 5 years ago

[Homescreen] Changing the 'Homescreen Settings' quickly/rapidly in their dropdown selection can cause unexpected changes

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1S --- affected
b2g-v2.2 --- affected
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: onelson, Assigned: arthurcc)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Description:
If a user attempts to modify their 'Homescreen Settings' column, numbers, they will observe that a drop down menu appears for a selection between 'Three Columns' and 'Four Columns'. The user can observe that if they are currently viewing "Three Columns", and quickly switch to "Four Columns" and back to "Three Columns", the app will maintain "Four Columns", though the last user action selected "Three Columns" (as they were originally). It has been observed also that the display showed inaccurately to the number of columns that were actually displaying at homescreen (ie: value of dropdown shows "Three Columns", but four columns would display; observed once).


Repro Steps:
1) Update a Flame to 20150320010204
2) Hold tap on the homescreen.
3) Select 'Homescreen Settings'.
4) Observe dropdown for Icon Layout: "Four Columns" | "Three Columns" (defaults to "Three Columns).
5) Tap "Three Columns" to open dropdown.
6) Quickly tap "Four Columns", "Three Columns", 'Done'.

Actual:
Dropdown Menu in Homescreen Settings will use the initial action performed by the user, and not their final before confirmation (Four Columns).
(Three Columns > Four Columns > Three Columns = Four Columns)

Expected:
Dropdown Menu in Homescreen Settings will use the final action performed by the user prior to confirmation (Three Columns).
(Three Columns > Four Columns > Three Columns = Three Columns)

Environmental Variables:
--------------------------------------------------

Device: Flame 3.0
Build ID: 20150320010204
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

--------------------------------------------------

Device: Flame 2.1
BuildID: 20150320001203
Gaia: 13c85d57f49b4bfd657ff674f2b530c141c94803
Gecko: 76bf2f0c7f07
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------

BuildID: 20150320000203
Gaia: 896803174633fc6acd3fd105f81c349b8e9b9633
Gecko: 4e229bde42dd
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
--------------------------------------------------


Repro frequency: 8/10
See attached: 
video
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
Forgot my 2.2 variables, and did not label 2.0 in previous comment.

--------------------------------------------------
Environmental Variables:
Device: Flame 2.2
BuildID: 20150318002504
Gaia: 306772a58335ac4cad285d27c3805090a8cc6886
Gecko: a6f5f4035ea5
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Device: Flame 2.0
BuildID: 20150320000203
Gaia: 896803174633fc6acd3fd105f81c349b8e9b9633
Gecko: 4e229bde42dd
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
--------------------------------------------------
Ni on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(hcheng)
I cannot reproduce this issue. Could you provide logcat?
Since it is not a usual case, I will not nominate this bug as a blocker.
Flags: needinfo?(hcheng) → needinfo?(onelson)
Here you go, I turned on 'Gaia Debug Traces' so hopefully it shows you what you need. Let me know if you need anything else.
Flags: needinfo?(onelson)
I tried but cannot find something unusual in log.
It occurs at Settings but I think it might be a window management issue.
However, I am not really sure. Arthur, could you take a look?
Flags: needinfo?(arthur.chen)
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Comment on attachment 8584130 [details] [review]
[gaia] crh0716:1145756 > mozilla-b2g:master

EJ, could you help review this simple patch? Thanks.
Attachment #8584130 - Flags: review?(ejchen)
Comment on attachment 8584130 [details] [review]
[gaia] crh0716:1145756 > mozilla-b2g:master

r+, thanks Arthur !!!
Attachment #8584130 - Flags: review?(ejchen) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Component: Gaia::Homescreen → Gaia::Settings
http://docs.taskcluster.net/tools/task-graph-inspector/#QQF90ApyQzq7XyyH8qJ7ag

The pull request failed to pass integration tests. It could not be landed, please try again.
All tests were passed: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=a49c91008ccec2b0d154abaa4f83c991039ea530

master: 1d14f4a6809de81ebd638117ed4ddd3b1b18f033
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame master and Aries KK master by the following STR. Because "Homescreen" had changed its design that there is no "Homescreen settings" option menu after long pressing Homescreen, so I must go to Settings-> Home Screens to verify this bug.

STR:
1) Go to Settings-> Home Screens.
2) Tap "Three Columns" to open dropdown (defaults to "Three Columns).
3) Quickly continuously tap "Four Columns", "Three Columns", "Four Columns", 'OK' (or continuously tap "Four Columns", "Three Columns", 'OK').

Actual results: Dropdown Menu in Homescreen Settings uses the final action performed by the user prior to confirmation.
See attachment: verified_Flame_master.3gp
Reproduce rate: 0/10


Device: Flame master_512mb (Pass)
Build ID               20151216150211
Gaia Revision          a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gaia Date              2015-12-16 06:59:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151216.185725
Firmware Date          Wed Dec 16 18:57:38 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151216115605
Gaia Revision          a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gaia Date              2015-12-16 06:59:39
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.113143
Firmware Date          Wed Dec 16 11:31:51 UTC 2015
Bootloader             s1

Device: Flame 2.5_512mb (Pass)
Build ID               20151217001512
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fc571094879466cb3ae35bc3bb32a7832bbfcade
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.232554
Firmware Date          Wed Dec 16 23:26:04 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151217001840
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fc571094879466cb3ae35bc3bb32a7832bbfcade
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.232744
Firmware Date          Wed Dec 16 23:27:52 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.