[Flame] Time does not display on status bar after waking up device if lockscreen is disabled

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: piwei, Assigned: albertopq)

Tracking

(Blocks: 1 bug, {regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master unaffected)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8580856 [details]
logcat on Flame 2.2

Description:
If device does not have lockscreen, the status bar will not initially display time/clock upon waking up, until there is change on the status bar such as minute changes on the time, or entering an app.

STR:
0) Disable lockscreen
1) Press power button twice to turn off and turn on the screen
2) Observe status bar

Expected: Time is displayed on status bar

Actual: Time is NOT displayed on status bar, until the clock advances to the next minute, or until user goes to another app.

Repro rate: 10/10

Video:
https://www.youtube.com/watch?v=shSyZwvJ2_M

Attaching a logcat.

Device: Flame 2.2
BuildID: 20150320002502
Gaia: c8136ef4094fc5509551ab7b1d5f6141491f00ef
Gecko: 12139abae350
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on Flame 3.0 and does NOT occur on Flame 2.1.

Device: Flame 3.0
BuildID: 20150320010204
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.1
BuildID: 20150320001203
Gaia: 13c85d57f49b4bfd657ff674f2b530c141c94803
Gecko: 76bf2f0c7f07
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
Let's get a reverse regression window here.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
b2g-inbound Reverse-Regression Window:

Last Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150303023847
Gaia: 6036295b7192e21c1370495617e5ab727575fea3
Gecko: 97c49ccbdfbf
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150303025447
Gaia: d9399ecd386aaf37214c4bffcaceca335c143413
Gecko: 11a4ffbd9ee9
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Broken Gaia First Working Gecko: Issue DOES reproduce 
Gaia: 6036295b7192e21c1370495617e5ab727575fea3
Gecko: 11a4ffbd9ee9

First Working Gaia Last Broken Gecko: Issue does NOT reproduce
Gaia: d9399ecd386aaf37214c4bffcaceca335c143413
Gecko: 97c49ccbdfbf

https://github.com/mozilla-b2g/gaia/compare/6036295b7192e21c1370495617e5ab727575fea3...d9399ecd386aaf37214c4bffcaceca335c143413

Possibly fixed by bug 1098168
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
Alive, can you take a look at this please? Looks like this fixed on master by the work done on bug 1098168. Can this be fixed on 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Cool. Michael, if this is 2.2+, are you able to find out someone to work on this on v2.2 without uplifting bug 1098168? I think it's possible to reuse hierarchytopmostwindowchanged event.
Flags: needinfo?(alive) → needinfo?(mhenretty)
(Assignee)

Comment 6

3 years ago
I'll take it. Thanks!
Assignee: nobody → apastor
Flags: needinfo?(mhenretty)
Created attachment 8581751 [details] [review]
[gaia] albertopq:1145760-time-statusbar-2.2-only > mozilla-b2g:v2.2
(Assignee)

Updated

3 years ago
Attachment #8581751 - Flags: review?(alive)

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8581751 [details] [review]
[gaia] albertopq:1145760-time-statusbar-2.2-only > mozilla-b2g:v2.2

Thanks!
Attachment #8581751 - Flags: review?(alive) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
This landed without approval. Please backout.
status-b2g-v2.2: affected → fixed
Flags: needinfo?(apastor)
Target Milestone: --- → 2.2 S9 (3apr)
Created attachment 8582394 [details] [review]
[gaia] albertopq:backout-v2.2 > mozilla-b2g:v2.2
(Assignee)

Comment 12

3 years ago
Sorry, I forgot this was a 2.2 only patch, and added checkin-needed as if it was master.

Backout: https://github.com/mozilla-b2g/gaia/commit/7024dd4c7a7c3616dc8f9f908759f00abc0deddd
(Assignee)

Comment 13

3 years ago
Comment on attachment 8581751 [details] [review]
[gaia] albertopq:1145760-time-statusbar-2.2-only > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: User won't see the time in the statusbar after waking up the phone without lockscreen
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): One liner that forces update icons visibility when the phone wakes up. Low risk.
[String changes made]:
Flags: needinfo?(apastor)
Attachment #8581751 - Flags: approval-gaia-v2.2?(bbajaj)
status-b2g-v2.2: fixed → affected

Updated

3 years ago
Attachment #8581751 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Keywords: verifyme
According to the STR of Comment 0, this bug has been successfully verified on latest Flame v2.2.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/5

Device: Flame 2.2 (Pass)
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041652
Firmware Date          Tue Mar 24 04:17:03 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Keywords: verifyme
Please ignore this build version.

> Device: Flame 2.2 (Pass)
> Build ID               20150324002504
> Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
> Gaia Date              2015-03-23 23:27:22
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
> Gecko Version          37.0
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150324.041652
> Firmware Date          Tue Mar 24 04:17:03 EDT 2015
> Bootloader             L1TC000118D0


Update Flame v2.2 build (Pass):
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
(Reporter)

Updated

2 years ago
Blocks: 1229905
You need to log in before you can comment on or make changes to this bug.