Closed Bug 1145779 Opened 7 years ago Closed 7 years ago

crash in [@ CFRelease | __CFBasicHashDrain ]

Categories

(Core :: Audio/Video, defect)

All
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1145101

People

(Reporter: Dolske, Assigned: jya)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-6392c1f2-be73-447f-b021-7987e2150320.
=============================================================

I'm still seeing crashes after bug 1143339, but with a slightly different stack than bug 1145101.

Same repeatability -- close a tab with a YouTube video, browser reliably crashes 10-15 seconds later.

bp-6392c1f2-be73-447f-b021-7987e2150320
bp-b6c63f37-71a1-4f4a-b000-814ef2150320
Blocks: 1143339
No longer blocks: 1145101
New stack:
0 	CoreFoundation 	CFRelease 	
1 	CoreFoundation 	__CFBasicHashDrain 	
2 	CoreFoundation 	CFRelease 	
3 	VideoToolbox 	VideoToolbox@0x9033 	
4 		@0x12627abe8 	
5 	XUL 	mozilla::AppleVDADecoder::Shutdown() 	dom/media/fmp4/apple/AppleVDADecoder.cpp

Old stack from bug 1143339:
0 	CoreFoundation 	CoreFoundation@0x188b7 	
1 	CoreFoundation 	CoreFoundation@0x28823 	
2 	CoreFoundation 	CoreFoundation@0x18a9d 	
3 	VideoToolbox 	VideoToolbox@0x9033 	
4 		@0x10c58abe8 	
5 	XUL 	mozilla::AppleVDADecoder::Shutdown() 	dom/media/fmp4/apple/AppleVDADecoder.cpp
This is actually the same crash location as bug 1145101 (judging from the "module_offset" in the raw dump, it's [@ CoreFoundation@0x188b7]). Also the crash rates for this signature haven't gone down: https://crash-stats.mozilla.com/report/list?range_unit=days&range_value=3&signature=CoreFoundation%400x188b7#tab-table

FWIW I'm also seeing this crash with the same steps to reproduce, and it's displaying as [@ CoreFoundation@xxxx] https://crash-stats.mozilla.com/report/index/23366e36-b32d-4aa5-9125-51e992150320
or as [@ mozilla::AVCCMediaDataDecoder::Shutdown() ] like in bug 1145101: https://crash-stats.mozilla.com/report/index/d1e14af7-88c5-4d10-aeca-506dd2150320
> This is actually the same crash location as bug 1145101
I meant same as bug 1143339.
Assignee: nobody → jyavenard
This is the same issue as bug 1145101.
The VideoToolBox framework is being unloaded but its APIs still access later.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145101
You need to log in before you can comment on or make changes to this bug.