Add links to the source in the mcMerge footer

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: emorley, Assigned: KWierso)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
https://github.com/mozilla/mcMerge

Wes, you up for this? :-)
(Assignee)

Comment 1

4 years ago
Sure.
Assignee: nobody → wkocher
(Reporter)

Comment 2

4 years ago
With mcMerge, we can now use pull requests (in the same way as Treeherder) and once a change is merged to master, it will auto-deploy within 5 mins :-)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1145834
(Assignee)

Comment 4

4 years ago
Created attachment 8581915 [details] [review]
Link to mcMerge PR #3

This adds both the link to the source repository on Github as well as a link to deploy.txt for the currently deployed revision of the repository.

Should I do some special handling for the not-deployed case (when running mcMerge out of a local file) since it likely won't match deploy.txt?
Attachment #8581915 - Flags: review?(emorley)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8581915 [details] [review]
Link to mcMerge PR #3

Have left some comments, but r+ either way - thank you for the PR :-)
Attachment #8581915 - Flags: review?(emorley) → review+
(Assignee)

Comment 6

4 years ago
Addressed the comments and merged:
https://github.com/mozilla/mcMerge/commit/fa05fd1041da7c8ae20229ee2de5ed80b61faebb
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
And the auto-deploy works!
(Reporter)

Comment 8

4 years ago
(In reply to Wes Kocher (:KWierso) from comment #7)
> And the auto-deploy works!

\o/ :-)
You need to log in before you can comment on or make changes to this bug.