[Messages][Settings] When opening messaging settings from the messages app, a selection field will display improper text

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: dharris, Assigned: eragonj)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

Description:
When opening the messaging settings from the Messages app, the button within the Auto Retrieve section will show small text, then bigger text, and then finally displaying the proper form of the button. This bug will not occur if the messaging settings are opened through the Settings app


Repro Steps:
1) Update a Flame to 20150320010204
2) Open Messages app
3) Tap on "..." and select "Settings"
4) Observe the selection field below "Auto Retrieve"


Actual:
The button will show the text "off" in a small size, then the text will become bigger, but still display "Off" and finally will display the correct Text "On Without Roaming" in button form


Expected:
The field will display the correct Text "On Without Roaming" in button form

Environmental Variables
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150320010204
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/WBq9ZVneXf4
This issue DOES occur on Flame 2.2

The button will show the text "off" in a small size, then the text will become bigger, but still display "Off" and finally will display the correct Text "On Without Roaming" in button form

Environmental Variables
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150320002502
Gaia: c8136ef4094fc5509551ab7b1d5f6141491f00ef
Gecko: 12139abae350
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


This issue does NOT occur on Flame 2.1

The field will display the correct Text "On Without Roaming" in button form

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150320001203
Gaia: 13c85d57f49b4bfd657ff674f2b530c141c94803
Gecko: 76bf2f0c7f07
Version: 34.0  
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
This happens in the Settings app.

I believe it does not happen in v2.1 because we're just slower to display this panel.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::Settings
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141020205719
Gaia: e09e1734ad523cf63351a28f6f84454319349fbe
Gecko: 4da1f6a151d6
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141020214218
Gaia: ba10744d64411a8a12ae68f7cf1ec3e3ac897d21
Gecko: bcc5df613d83
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: e09e1734ad523cf63351a28f6f84454319349fbe
Gecko: bcc5df613d83

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: ba10744d64411a8a12ae68f7cf1ec3e3ac897d21
Gecko: 4da1f6a151d6

https://github.com/mozilla-b2g/gaia/compare/e09e1734ad523cf63351a28f6f84454319349fbe...ba10744d64411a8a12ae68f7cf1ec3e3ac897d21

Possibly caused by bug 1007600
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Arthur, can you take a look at this please? Looks like the work done on bug 1007600 might be the culprit here.
Blocks: 1007600
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(arthur.chen)
blocking-b2g: 2.2? → 2.2+

Comment 5

4 years ago
EJ will take a look first
Assignee: nobody → ejchen
Thanks, EJ!
Flags: needinfo?(arthur.chen)
Comment on attachment 8582849 [details] [review]
[gaia] EragonJ:bug-1145835 > mozilla-b2g:master

Arthur, can you help me check this patch ? Thanks :)
Attachment #8582849 - Flags: review?(arthur.chen)
Comment on attachment 8582849 [details] [review]
[gaia] EragonJ:bug-1145835 > mozilla-b2g:master

r=me, thanks.
Attachment #8582849 - Flags: review?(arthur.chen) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8582849 [details] [review]
[gaia] EragonJ:bug-1145835 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: users will see a bad-looking "select" element at first, then back to normal.
[Testing completed]: with manual test
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no

I just changed the loading sequences of styles to make sure those shared styles would be loaded at first before loading panels. And after test, this do fix the problem.
Attachment #8582849 - Flags: approval-gaia-v2.2?
Attachment #8582849 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is not fixed on Flame Master and 2.2.

Result: Although the text size appears correctly (not in smaller size), "Off" shows up first before "On Without Roaming" appears.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150401162503
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
As comment 13 suggested, the fix only fixed first part of the problem, specifically the button style incorrect problem is fixed. But considering all the rest of the elements on the page don't get loaded right away either, I'm marking this as verified.

Uploaded a video showing current behavior which I think is good enough.

https://www.youtube.com/watch?v=xcqmmfCqSSI

If we want to make a bug about current behavior we should make it so that all elements on this page aren't loaded as soon as it opens, and not limited to one element.

Verified on:
Device: Flame 2.6
BuildID: 20151207030216
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 528ea05671e9bd9ccb33d1558a20691a72c85f98
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Aries 2.6
BuildID: 20151207143802
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 59bc3c7a83de7ffb611203912a7da6ad84535a5a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5
BuildID: 20151207121611
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: c491dedc389de5c4686543b990c92d4f47715ee8
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.2
BuildID: 20151207032502
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 4381c4b69b9c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
> If we want to make a bug about current behavior we should make it so that all elements on this page aren't loaded as soon as it opens, and not limited to one element.

I don't properly understand this; I see that all "switches" element are the same. Or do you mean that we should have it like the whole page is displayed at once including headers ?

Anyway this is a separate issue IMO, worth filing a separate bug.
You need to log in before you can comment on or make changes to this bug.