Closed Bug 1145851 Opened 6 years ago Closed 5 years ago

Android 4.3 testNewTab | Exception caught - junit.framework.AssertionFailedError: Click can not be completed!

Categories

(Firefox for Android Graveyard :: Testing, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1207877

People

(Reporter: gbrown, Assigned: gbrown)

Details

On the Android 4.3 emulator, testNewTab frequently fails.

http://ftp.mozilla.org/pub/mozilla.org/mobile/try-builds/gbrown@mozilla.com-ab5e06e63b6e/try-android-api-9/try_ubuntu64_vm_mobile_test-robocop-2-bm114-tests1-linux64-build66.txt.gz

17:38:18     INFO -  TEST-START | testNewTab
17:38:18     INFO -  TEST-PASS | testNewTab | Robocop tests need the test device screen to be powered on. - 
17:38:18     INFO -  TEST-PASS | testNewTab | Given message occurred for registered event: {"type":"Gecko:Ready"} - Gecko:Ready should equal Gecko:Ready
17:38:18     INFO -  EventExpecter: no longer listening for Gecko:Ready
17:38:18     INFO -  TEST-PASS | testNewTab | Checking elements - all elements present
17:38:18     INFO -  TEST-PASS | testNewTab | Initial number of tabs correct - 1 should equal 1
17:38:18     INFO -  TEST-PASS | testNewTab | waiting for add tab view - add tab view available
17:38:18     INFO -  0 ERROR Exception caught during test! - junit.framework.AssertionFailedError: Click can not be completed!
17:38:18     INFO -  	at junit.framework.Assert.fail(Assert.java:50)
17:38:18     INFO -  	at junit.framework.Assert.assertTrue(Assert.java:20)
17:38:18     INFO -  	at com.jayway.android.robotium.solo.Clicker.clickOnScreen(Clicker.java:99)
17:38:18     INFO -  	at com.jayway.android.robotium.solo.Clicker.clickOnScreen(Clicker.java:182)
17:38:18     INFO -  	at com.jayway.android.robotium.solo.Clicker.clickOnScreen(Clicker.java:156)
17:38:18     INFO -  	at com.jayway.android.robotium.solo.Solo.clickOnView(Solo.java:974)
17:38:18     INFO -  	at org.mozilla.gecko.tests.BaseTest.addTab(BaseTest.java:617)
17:38:18     INFO -  	at org.mozilla.gecko.tests.testNewTab.addTab(testNewTab.java:16)
17:38:18     INFO -  	at org.mozilla.gecko.tests.BaseTest.addTab(BaseTest.java:639)
17:38:18     INFO -  	at org.mozilla.gecko.tests.testNewTab.addTab(testNewTab.java:16)
17:38:18     INFO -  	at org.mozilla.gecko.tests.testNewTab.testNewTab(testNewTab.java:38)
17:38:18     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
17:38:18     INFO -  	at java.lang.reflect.Method.invoke(Method.java:525)
17:38:18     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
17:38:18     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
17:38:18     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
17:38:18     INFO -  	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:132)
17:38:18     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:134)
17:38:18     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:115)
17:38:18     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:133)
17:38:18     INFO -  	at junit.framework.TestResult.run(TestResult.java:118)
17:38:18     INFO -  	at junit.framework.TestCase.run(TestCase.java:124)
17:38:18     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
17:38:18     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
17:38:18     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
17:38:18     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
17:38:18     INFO -  
17:38:18  WARNING -  TEST-UNEXPECTED-FAIL | testNewTab | Exception caught - junit.framework.AssertionFailedError: Click can not be completed!
17:38:18     INFO -  TEST-OK | testNewTab | took 68277ms
17:38:18     INFO -  TEST-START | Shutdown
17:38:18     INFO -  Passed: 5
17:38:18     INFO -  Failed: 1
I can no longer repro this failure and the test has been re-enabled in ...
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [test disabled on android 4.3]
Duplicate of bug: 1207877
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.