MOZ_ASSERT(mSetActiveTask == nullptr) failing at ActiveElementManager.cpp:91

RESOLVED DUPLICATE of bug 1169802

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1169802
3 years ago
3 years ago

People

(Reporter: botond, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

3 years ago
STR:
  1. Run a debug build of b2g.
  2. Load http://cnn.it/1H9l370
  3. Scroll up and down for a while

Relevant part of stack trace:

Program received signal SIGSEGV, Segmentation fault.
0xb4b1d74c in mozilla::layers::ActiveElementManager::TriggerElementActivation (this=0xb1934820) at /home/botond/dev/mozilla/central/gfx/layers/apz/util/ActiveElementManager.cpp:91
91          MOZ_ASSERT(mSetActiveTask == nullptr);
(gdb) i s
#0  0xb4b1d74c in mozilla::layers::ActiveElementManager::TriggerElementActivation (this=0xb1934820) at /home/botond/dev/mozilla/central/gfx/layers/apz/util/ActiveElementManager.cpp:91
#1  0xb4b246b2 in mozilla::layers::APZEventState::ProcessAPZStateChange (this=this@entry=0xb193b740, aDocument=..., aViewId=<optimized out>, 
    aChange=mozilla::layers::GeckoContentController::StartTouch, aArg=1) at /home/botond/dev/mozilla/central/gfx/layers/apz/util/APZEventState.cpp:357
#2  0xb53b4564 in mozilla::dom::TabChild::RecvNotifyAPZStateChange (this=0xb20d6400, aViewId=@0xbec9fae0: 3, aChange=@0xbec9fad4: mozilla::layers::GeckoContentController::StartTouch, 
    aArg=@0xbec9fadc: 1) at ../../../dom/ipc/TabChild.cpp:2130
(Reporter)

Comment 1

3 years ago
I suspect this is a regression from bug 1142437, as I can't repro it with its fix backed out.
Blocks: 1142437
(Reporter)

Comment 2

3 years ago
Actually, I can't repro this at all, with or without bug 1142437, so I have no grounds to suspect it. It just seems to be very intermittent.
No longer blocks: 1142437
(Reporter)

Updated

3 years ago
Whiteboard: [gfx-noted]
Forward-duping since bug 1169802 has a log
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169802
You need to log in before you can comment on or make changes to this bug.