[e10s] Dropdown combobox doesn't stay open

RESOLVED DUPLICATE of bug 1049285

Status

()

defect
RESOLVED DUPLICATE of bug 1049285
4 years ago
4 years ago

People

(Reporter: raysatiro, Unassigned)

Tracking

({polish})

39 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150320030211

Steps to reproduce:

http://www-odi.nhtsa.dot.gov/owners/SearchSafetyIssues

For 'Model Year' select 9999
For 'Make' click on the dropdown box or arrow


Actual results:

The dropdown opens and then closes quickly. It doesn't stay open like it should. There is no time to make a selection. An animated gif that demonstrates the problem is attached.


Expected results:

The dropdown should stay open. I notice this problem is only with e10s windows and when there isn't enough room for the dropdown to actually drop down below its widget. If I scroll down the page and then click on the dropdown it stays open, I assume because it has the room to actually drop down.
Reporter

Updated

4 years ago
tracking-e10s: --- → ?
Reporter

Updated

4 years ago
Blocks: e10s

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Blocks: 1082510
Additional bug detail:

You need to place the combo box near the bottom of your screen, such that the combo box drop down window displays underneath the mouse pointer.

The actual bug here:

The combo box drop down window places its lower left origin at the lower left origin of the combo element. The popup origin should be places at the upper left corner of the combo element.

This only reproduces in e10s afaict.

Updated

4 years ago
Keywords: polish

Updated

4 years ago
No longer blocks: e10s, 1082510
Status: NEW → RESOLVED
Closed: 4 years ago
No longer depends on: 1049285
Resolution: --- → DUPLICATE
Duplicate of bug: 1049285
You need to log in before you can comment on or make changes to this bug.