Newsgroups: Dialog for 'download max number of headers' will not appear for following subscribed NG if once set to "0"

RESOLVED FIXED in Thunderbird 44.0

Status

MailNews Core
Backend
RESOLVED FIXED
16 years ago
2 years ago

People

(Reporter: Stefan Moebius, Assigned: Magnus Melin)

Tracking

Trunk
Thunderbird 44.0

Firefox Tracking Flags

(firefox42 affected, seamonkey2.35 affected, seamonkey2.39 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using build 2001121003.
If you subscribe to a newsgroup but set the number of articles to "0" you will
never be prompted again and _all_ articles will be downloaded instead.

Reproducible: Always
Steps to reproduce:
1. Subscribe to two large newsgroups (>500 posts)
2. Select the first one
  -> You will be prompted whether you want to download 500 or all posts
3. Change the number to zero and click Download
  -> Nothing happens (as expected)
4. Select the second newsgroup
Actual result:
  -> MailNews starts downloading _all_ post in that newsgroup
Expected result:
  The dialog should open up again, asking for the number of posts to be
  downloaded.

I changed prefs.js: mail.server.server3.max_articles to some other value and it
worked again.

Comment 1

16 years ago
Confirmed with 2001-12-12-03 under W2K
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Perhaps we shouldn't allow 0.  There's a preference in the Account Settings for
a news server that should allow this to be changed.  Did that not work?
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 3

16 years ago
That does work. But I found that pref only after I filed the bug. But I think
that mozilla's behavior is not very intuitive here.
Product: Browser → Seamonkey

Updated

12 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW

Updated

9 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---
Assignee: mail → nobody
QA Contact: search → message-display
Status: REOPENED → UNCONFIRMED
Target Milestone: Future → ---

Comment 6

2 years ago
Still REPRIDUCIBLE with German SeaMonkey 2.32.1 Build 20150204202218 on German WIN7 64bit
I tried with de.comm.software.mozilla.browser and de.comm.software.mozilla.mailnews, see effect as reported. 
I will do some further research concerning the roots of the problem before I will confirm.

Comment 7

2 years ago
Still REPRODUCIBLE with  SeaMonkey DE 2.39a1 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0  Build 20150728011950  (Classic Theme) on German WIN7 64bit

10. Add news account with server news.aioe.org  → Port  119 → no security
   Click Account → Server Settings → Ask me before downloading more than xxx
   Messages, modify xxx to "500" if necessary 
11. Click new account → Manage News Subscriptions
12. Subscribe to "alt.comp.os.windows-8" and alt.comp.os.windows-10" [ok]
13. Further proceeding as per User Story step 2 and following

Still reproducible, for second NG all news will be downloaded without ssikng again

Additional Information
----------------------

a) I also did a Test with TB nightly 42.0a1 (2015-07-25), also reproducible, 
   so CORE problem.
b) I observed an additional strange thins in SM an TB: After the test the server 
   setting for max. downloads was modified to "1" (from "500"). I think 
   that setting should not be modified, this is a separate bug
c) It seems "Ask me before downloading more than 0 messages" is not allowed,
   minimum value is "1"? At least the problem does not appear if I use "1" 
   instead of "0" in user story step 3
status-firefox42: --- → affected
status-seamonkey2.35: --- → affected
status-seamonkey2.39: --- → unaffected
Component: MailNews: Message Display → Backend
OS: Windows 2000 → Windows
Product: SeaMonkey → MailNews Core
Summary: Can't change max_article once set to zero → Newsgroups: Dialog for 'download max number of headers' will not appear for following subscribed NG if once set to "0"

Comment 8

2 years ago
d) I did not find DUPlicates with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs114607&sharer_id=41036&list_id=12435373>
Status: UNCONFIRMED → NEW
status-seamonkey2.39: unaffected → affected
Ever confirmed: true
(Assignee)

Comment 9

2 years ago
Probably due to http://mxr.mozilla.org/comm-central/source/mailnews/news/src/nsNNTPProtocol.cpp#2963
2962   // if the user sets max_articles to a bogus value, get them everything
2963   m_numArticlesWanted = m_maxArticles > 0 ? m_maxArticles : 1L << 30;
(Assignee)

Comment 10

2 years ago
Created attachment 8656761 [details] [diff] [review]
bug114607_dl_ngs_0.patch

Ah yes. 
On ok the dialog sets the 
nntpServer.maxArticles = numberElement.value;

... which if it got set to 0 gets set so something really large, per my comment above.

Let's just set the minnimum allowed to 1
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8656761 - Flags: review?(acelists)

Comment 11

2 years ago
So when the user does not want any messages downloaded, should he press cancel instead of inputting 0?
(Assignee)

Comment 12

2 years ago
That would be logical, no?

Comment 13

2 years ago
Comment on attachment 8656761 [details] [diff] [review]
bug114607_dl_ngs_0.patch

Review of attachment 8656761 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, and the maxArticles is a server value, not per newsgroup.

> Bug 114607 - set minimum number allowd to 1 in "donwload max number of headers' dialog. r=?
Please fix the typos in "allowd" and the "donwload" and the mismatched quotes :)
Attachment #8656761 - Flags: review?(acelists) → review+
(Assignee)

Comment 14

2 years ago
https://hg.mozilla.org/comm-central/rev/4a0c3b7df040 -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago2 years ago
OS: Windows → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0

Comment 15

2 years ago
You didn't fix the typos ;)
You need to log in before you can comment on or make changes to this bug.