Closed Bug 1146078 Opened 7 years ago Closed 7 years ago

Failing unit test on TC, Search mode Search by name & surname with trailing whitespaces

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

Attachments

(2 files)

TEST-UNEXPECTED-FAIL | null | [communications-contacts/test/unit/search_test.js] Search mode Search by name & surname with trailing whitespaces
Error: TypeError: imgLoader is undefined (app://communications.gaiamobile.org/shared/js/contacts/search.js?time=1426975014770:488)
    at onerror (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4959:10)

https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/HXfU8TFpQl6M8y6OwPgsrA/4/public/logs/live_backing.log
Comment on attachment 8581232 [details] [review]
[gaia] KevinGrandon:bug_1146078_debug_failing_tc_contact_test > mozilla-b2g:master

Francisco - got time for a quick review? After several re-triggers I think this might solve the races of the test. Thanks!
Attachment #8581232 - Flags: review?(francisco)
Blocks: 1109925
Comment on attachment 8581232 [details] [review]
[gaia] KevinGrandon:bug_1146078_debug_failing_tc_contact_test > mozilla-b2g:master

LGTM, thanks Kevin!
Attachment #8581232 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/pull/29037

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Duplicate of this bug: 1146258
Manually landed due to tree closure: https://github.com/mozilla-b2g/gaia/commit/84e6931b468f58e8df6436a18f409d082a7f58c4
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1146259
Duplicate of this bug: 1163527
Blocks: 1149886
You need to log in before you can comment on or make changes to this bug.