Closed Bug 1146097 Opened 5 years ago Closed 5 years ago

Incorrectly escaped regexp in webide-prefs.js

Categories

(DevTools :: WebIDE, defect)

x86_64
macOS
defect
Not set

Tracking

(firefox39 fixed)

RESOLVED FIXED
Firefox 39
Tracking Status
firefox39 --- fixed

People

(Reporter: jruderman, Assigned: janx)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

In browser/devtools/webide/webide-prefs.js:

> pref("devtools.webide.simulatorAddonRegExp", "fxos_(.*)_simulator@mozilla\.org$");

Trips a warning on a startup:

WARNING: preserving unexpected JS escape sequence: file modules/libpref/prefread.cpp, line 393

Assuming you want the parsed pref (and thus input to the regexp engine) to contain "\.", I think the prefs file should contain "\\."
Thanks for reporting this, Jesse!

> Assuming you want the parsed pref (and thus input to the regexp engine) to
> contain "\.", I think the prefs file should contain "\\."

That's indeed what was intended, fixed using your suggestion.
Attachment #8581293 - Attachment is obsolete: true
Attachment #8581294 - Flags: review?(jruderman)
Attachment #8581294 - Flags: review?(jruderman) → review+
Thanks! We are ready for launch.
Keywords: checkin-needed
Assignee: nobody → janx
https://hg.mozilla.org/mozilla-central/rev/db88094d97b2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.