B2G emulator permafail layout/reftests/floats/float-in-rtl-4a.html, float-in-rtl-4b.html, float-in-rtl-4c.html, float-in-rtl4d.html | image comparison (==), max difference: 3, number of differing pixels: 1

RESOLVED FIXED in mozilla39

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

Trunk
mozilla39
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

This intermittent reftest failure:
REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/floats/float-in-rtl-4a.html | image comparison (==), max difference: 3, number of differing pixels: 1
REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/floats/float-in-rtl-4b.html | image comparison (==), max difference: 3, number of differing pixels: 1
REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/floats/float-in-rtl-4c.html | image comparison (==), max difference: 3, number of differing pixels: 1
REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/floats/float-in-rtl-4d.html | image comparison (==), max difference: 3, number of differing pixels: 1 


The difference is a single pixel where the text barely overlaps the float; in the test it's #ef2626, whereas in the reference it's #f22626 (the color of the float).
Comment hidden (Treeherder Robot)
Given overlap, I would expect this difference, since the reference has position:relative on the things simulating floats, which means that even though they're before the text, they should still be above it in z-order.

It's not clear to me why there's intermittent overlap, but the easy fix seems to be adding 2px of margin to the floats.
Flags: needinfo?(jfkthame)
Oops, philor points out it's not intermittent, but a regression from https://hg.mozilla.org/integration/mozilla-inbound/rev/fb05b4b128da .

I think z-index is probably a better fix.
Flags: needinfo?(jfkthame)
Summary: intermittent layout/reftests/floats/float-in-rtl-4a.html, float-in-rtl-4b.html, float-in-rtl-4c.html, float-in-rtl4d.html | image comparison (==), max difference: 3, number of differing pixels: 1 → B2G emulator permafail layout/reftests/floats/float-in-rtl-4a.html, float-in-rtl-4b.html, float-in-rtl-4c.html, float-in-rtl4d.html | image comparison (==), max difference: 3, number of differing pixels: 1
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
If that still doesn't work (reftests are currently pending...), an alternative would be to append  ‎ to the text in each of the files for test 4, so that we have whitespace separating the end of the text from the colored float block. (I think that'd be simpler than messing with margins or padding to create the separation in this case.)
https://hg.mozilla.org/mozilla-central/rev/ae395a4d961a
https://hg.mozilla.org/mozilla-central/rev/e0f47fcda5cd

(Not sure why this wasn't marked when the merge happened.)
Assignee: nobody → dbaron
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.