Closed Bug 114615 Opened 19 years ago Closed 19 years ago

"Search for" in selection context menu sure includes a lot

Categories

(SeaMonkey :: Search, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.8

People

(Reporter: rune, Assigned: samir_bugzilla)

References

()

Details

(Whiteboard: [ready to checkin])

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011210
BuildID:    2001121003

When selecting text that contains images, <br>/<p> tags etc. the "Search for"
menu item includes #10#13 and image location/alt text. See URL for demonstration.

Reproducible: Always
Steps to Reproduce:
1. Go to URL
2. Follow descriptions, select tree numbers, right click.
3. Look at the "Search for" menu item

Expected Results:  Stripped of the codes, only including visible text.
Confirmed, winXP, 2001121003.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed, build 2001121003, WinNT SP6a
->search
Assignee: pchen → sgehani
Component: XP Apps → Search
QA Contact: sairuh → claudius
We need to strip:
(*) whitespace of the form tabs, linefeeds, and carriage returns
(*) tags in the selection
wfm 2001121103 on win2k.

It never reads more than "Search for 'Test 1; select ...'"
Dean, 
Select only the digits 1, 2, the image, and then digit 3.  Don't select the
instructions.  This will display the problem.
morse, please r.
alecf, please sr.

Will land this when landing the patch for bug 15176.

(Not stripping tags because the DOM's getSelection API munges the tags and
supplies strings that makes sense.)
Status: NEW → ASSIGNED
Keywords: patch, review
Priority: -- → P3
Target Milestone: --- → mozilla0.9.7
well, isn't that pretty!  ok, forget that wfm comment.
Comment on attachment 61354 [details] [diff] [review]
Strip cr, lf, tabs.

r=morse
Attachment #61354 - Flags: review+
Comment on attachment 61354 [details] [diff] [review]
Strip cr, lf, tabs.

sr=alecf
Attachment #61354 - Flags: superreview+
OS: Windows 2000 → All
Hardware: PC → All
This patch is r, sr and risk is really minimal. Should perhaps be fixed. One
less in the the 0.9.7 long list :)
Keywords: review
Whiteboard: [ready to checkin]
Target Milestone: mozilla0.9.7 → mozilla0.9.8
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.