{css-moz} Rendering problems with SELECT border size [border][gfx]

RESOLVED DUPLICATE of bug 106317

Status

()

RESOLVED DUPLICATE of bug 106317
17 years ago
17 years ago

People

(Reporter: jond, Assigned: attinasi)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
SELECT elements in a FORM will only use a border size of 2 px.  No matter how
the behavior is modified in an applicable CSS specification, all SELECT elements
will now only render with a 2 px border size.

In my tests, I modified the select {} entry in the aform.css sample provided
with Mozilla and then selected the "Style A" button to test the changes.  I
changed the border property as follows:

border: 5px inset rgb(192,192,192);

Upon reloading and reselecting "Style A" there was no change where expected.  I
also changed the border to 1 px and 10 px.  To make sure that my changes were
actually occuring, I changed the above propert (-moz-border-radius) to 5px.  The
rounded corners appeared but with a 2 px border size.

This behavior is different than Mozilla 0.9.5 builds where it did render the
appropriate border sizes.  I first noticed the change in behavior with the 0.9.6
milestone release.

I am aware of a means of forcing user-defined styles to override anything else,
but even making the change in defaults/profile/US/chrome/userContent.css with
the !important tag would not render correctly.

I have only been able to test with a Mac build thus far, but it is definite that
it is affecting the builds for classic Mac OS.  I will test it on a few other
platforms and update this bug entry with the results.
This was, unfortunately a purposeful change

*** This bug has been marked as a duplicate of 106317 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.