crash in CoreFoundation@0x19217

RESOLVED DUPLICATE of bug 1145101

Status

()

--
critical
RESOLVED DUPLICATE of bug 1145101
4 years ago
4 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({crash, topcrash-mac})

Trunk
All
Mac OS X
crash, topcrash-mac
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-481f64a0-8cf0-4af1-8190-7467b2150320.
=============================================================

Frame 	Module 	Signature 	Source
Ø 0 	CoreFoundation 	CoreFoundation@0x19217 	
Ø 1 	CoreFoundation 	CoreFoundation@0x284ef 	
Ø 2 	CoreFoundation 	CoreFoundation@0x19397 	
Ø 3 	VideoToolbox 	VideoToolbox@0x6cc4 	
4 		@0x10c4dfbee 	
5 	XUL 	mozilla::AppleVDADecoder::Shutdown() 	dom/media/fmp4/apple/AppleVDADecoder.cpp
6 	XUL 	mozilla::AVCCMediaDataDecoder::Shutdown() 	dom/media/fmp4/AVCCDecoderModule.cpp
7 	XUL 	mozilla::SharedDecoderManager::Shutdown() 	dom/media/fmp4/SharedDecoderManager.cpp
8 	XUL 	mozilla::MediaSourceReader::ContinueShutdown() 	dom/media/mediasource/MediaSourceReader.cpp
9 	XUL 	mozilla::MediaPromise<bool, bool, false>::ThenValue<mozilla::MediaSourceReader, void (mozilla::MediaSourceReader::*)(), void (mozilla::MediaSourceReader::*)()>::DoResolve(bool) 	obj-firefox/x86_64/dist/include/MediaPromise.h
10 	XUL 	mozilla::MediaPromise<bool, bool, false>::ThenValueBase::ResolveRunnable::Run() 	dom/media/MediaPromise.h
11 	XUL 	mozilla::MediaTaskQueue::Runner::Run() 	dom/media/MediaTaskQueue.cpp
12 	XUL 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp
13 	XUL 	_ZThn8_N12nsThreadPool3RunEv 	obj-firefox/x86_64/xpcom/threads/Unified_cpp_xpcom_threads0.cpp
14 	XUL 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
15 	XUL 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
16 	XUL 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
17 	XUL 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
18 	XUL 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
19 	libnss3.dylib 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c
Ø 20 	libsystem_pthread.dylib 	libsystem_pthread.dylib@0x1898 	
Ø 21 	libsystem_pthread.dylib 	libsystem_pthread.dylib@0x1729 	
Ø 22 	libsystem_pthread.dylib 	libsystem_pthread.dylib@0x5fc8 	
23 	libnss3.dylib 	libnss3.dylib@0x208cff
This is probably bug 1145101, which should be fixed in today's Nightly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145101
You need to log in before you can comment on or make changes to this bug.