If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Image in Media Gallery is deleted if you edit its description and then want to upload a new image

RESOLVED FIXED

Status

support.mozilla.org
Knowledge Base Software
P3
critical
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: upwinxp, Assigned: rehan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=gallery p=2 s=2015.7)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
edwin-sumo
Created attachment 8581617 [details]
Steps to reproduce

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150319212106

Steps to reproduce:

1. Edit the description of any image and save it.
2. Click "Upload a New Media File".


Actual results:

There is an image with changed description. If you click Cancel or Delete an image (to upload a new image), it's deleted. (See the attached video)


Expected results:

The image should not appear in the Upload a New Media File panel.

Comment 1

3 years ago
I can confirm this bug.  Since it involves data loss (images that appear in KB articles can be deleted) I marked it critical. Related discussion:
https://support.mozilla.org/en-US/forums/contributors/711049 Bugs on SUMO posted January 28, 2015
https://support.mozilla.org/en-US/forums/contributors/709824 Media Gallery upload bug - has anyone else seen this? posted December 8, 2013
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

Updated

3 years ago
Component: General → Knowledge Base Software
Yeah, this is pretty bad. I'm not sure what is going on here. Estimating this at two points to dig into what is going on. Hopefully it is a simple fix.
Whiteboard: u=contributor c=gallery p=2 s=2015.6

Updated

3 years ago
Priority: P2 → P3
Moving to next sprint
Whiteboard: u=contributor c=gallery p=2 s=2015.6 → u=contributor c=gallery p=2 s=2015.7
(Assignee)

Updated

3 years ago
Assignee: nobody → rdalal
Status: NEW → ASSIGNED
PR: https://github.com/mozilla/kitsune/pull/2487
I merged this in: https://github.com/mozilla/kitsune/commit/8d7507192ec60206ad9fd5c98c12f6107af2462f

This can't be deployed because Django 1.7 has been merged, and we can't deploy Django 1.7 (or any other celery changes) until bug 1158971 is fixed.
Depends on: 1158971
I deployed this to prod now.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.