crash in java.lang.NullPointerException: at org.mozilla.gecko.overlays.ui.ShareDialog.handleSendTabUIEvent(ShareDialog.java)

RESOLVED DUPLICATE of bug 1145892

Status

()

Firefox for Android
Overlays
--
critical
RESOLVED DUPLICATE of bug 1145892
3 years ago
a year ago

People

(Reporter: Flaviu Cos, Assigned: mcomella)

Tracking

({crash})

Trunk
All
Android
crash
Points:
---

Firefox Tracking Flags

(fennec38+)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-7f28cb64-1927-46c3-895e-7d6252150323.
=============================================================
Environment: 
Device: Asus Transformer Tab (Android 4.2.1);
Build: Nightly 39.0a1 (2015-03-23);

Steps to reproduce:
1. Launch Fennec;
2. Log in with a valid FX Account;
3. Wait until the sync process is finished. 
4. Go to Settings -> Sync -> Remove Account;
5. Load a page and tap on Options -> Share -> Send to other devices.

Expected result:
'Send to other devices' option is not available.

Actual result:
Fennec crashes.

Java Stack Trace:

java.lang.NullPointerException
	at org.mozilla.gecko.overlays.ui.ShareDialog.handleSendTabUIEvent(ShareDialog.java:109)
	at org.mozilla.gecko.overlays.ui.ShareDialog$1.onReceive(ShareDialog.java:90)
	at android.support.v4.content.LocalBroadcastManager.executePendingBroadcasts(Unknown Source)
	at android.support.v4.content.LocalBroadcastManager.access$000(Unknown Source)
	at android.support.v4.content.LocalBroadcastManager$1.handleMessage(Unknown Source)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:5039)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560)
	at dalvik.system.NativeStart.main(Native Method)

Updated

3 years ago
tracking-fennec: --- → ?
Component: General → Overlays
Imma pre-emptively assign this one to mcomella :)
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Pretty sure this is bug 1145892.

Flaviu, please reopen if you see this again.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145892
tracking-fennec: ? → 38+
You need to log in before you can comment on or make changes to this bug.