If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WebRTC Hello does not support 720p and above

RESOLVED INCOMPLETE

Status

Hello (Loop)
General
RESOLVED INCOMPLETE
3 years ago
7 months ago

People

(Reporter: Alex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20150323])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Hello I was trying Firefox Hello 


Actual results:

and I've noticed that it runs only in 640x480



Expected results:

it should display 720p video.
I have a HD cam and both side have a very good internet connection.
If I join the conversation with chromium, it works in 720p

I tried to force settings with this parameters in about:config
media.navigator.video.default_height
media.navigator.video.default_width
but it does not work, video does not display.

when I go on theese site HD video does not works, it render only 640*480.
chromium works well

http://simpl.info/getusermedia/constraints/
http://demo.easyrtc.com/demos/demo_audio_video_simple_hd.html

I'm on Linux mint 17.1
webcam logitech c525
(Reporter)

Updated

3 years ago
OS: Windows 7 → Linux

Updated

3 years ago
Component: Untriaged → General
Product: Firefox → Loop
Summary: Webrtc hello does not support 720p and above → WebRTC Hello does not support 720p and above
Whiteboard: [bugday-20150323]
Version: 36 Branch → unspecified
Adam, any idea on if this is something we need to handle or tokbox?
Flags: needinfo?(adam)

Comment 2

2 years ago
(In reply to Mark Banner (:standard8) from comment #1)
> Adam, any idea on if this is something we need to handle or tokbox?

This is probably going to be on our side. I'd have the platform folks look into it first, as I know there have been some issues with constraints processing as it relates to video resolution.

I'm tagging Jan-Ivar and Jesup here to see if they have suggestions for fixing the issue.
Flags: needinfo?(rjesup)
Flags: needinfo?(jib)
Flags: needinfo?(adam)
Many things here. Let me separate WebRTC from Hello and do Hello first.

(In reply to Alex from comment #0)
> Hello I was trying Firefox Hello 
> 
> Actual results:
> 
> and I've noticed that it runs only in 640x480

AFAIK Firefox Hello is currently using the default (640x480) resolution always. Using higher 16:9 camera resolutions here seems worth exploring, especially in the detached full window rather than the small conversation window, or when connecting from a Hello web-page. This would be a Hello specific request.

Next, lets address the other claims about WebRTC.

> Expected results:
> 
> it should display 720p video.
> I have a HD cam and both side have a very good internet connection.
> If I join the conversation with chromium, it works in 720p

This surprises me... When I try a Hello link in Chrome, I see a 4:3 aspect self-view. Chrome defaults to 640x480 in WebRTC demos as well. Could you double-check this and give me steps to reproduce?

> I tried to force settings with this parameters in about:config
> media.navigator.video.default_height
> media.navigator.video.default_width
> but it does not work, video does not display.

These work for me, but I'm not on linux. Could you double-check? Do you have steps to reproduce? Please file a separate bug on this.

> when I go on theese site HD video does not works, it render only 640*480.
> chromium works well
> 
> http://simpl.info/getusermedia/constraints/

This is a separate problem. This demo (a copy of webrtc) uses non-standard Chrome-only constraints. Read about the difference here [1].

I've had a PR pending for a while to update those samples with a standards polyfill. Please try my PR instead [2] and let me know if it works for you!

> http://demo.easyrtc.com/demos/demo_audio_video_simple_hd.html

Same here. easyrtc seems to only support non-standard Chrome-specific constraints. We should reach out to them.

> I'm on Linux mint 17.1
> webcam logitech c525

FWIW my tests here were with Windows 7 logitech c910, as well as Facetime cam on MBP OSX.

[1] http://stackoverflow.com/questions/28282385/webrtc-firefox-constraints/28911694#28911694
[2] http://htmlpreview.github.io/?https://raw.githubusercontent.com/jan-ivar/samples/polyconstraints/src/content/getusermedia/resolution/index.html
Flags: needinfo?(jib)
Here's the polyfill PR for those who want to track it: https://github.com/webrtc/samples/pull/493
Since the MJPEG fixes landed and uplifted (to 38 IIRC), there's no reason we can't use higher resolution. Note that this will increase the CPU load both for sender and receiver, and for the person using the "small" window sending 720 to them is way overkill - but we also don't have RTPsender settings to scale down the video yet, and we don't have the ability to change the capture resolution on the fly.
Flags: needinfo?(rjesup)
(In reply to Randell Jesup [:jesup] from comment #5)
> for the person using the "small" window sending 720 to them is way overkill

Except the person can undock the chat window to full size at any time, at which point the low resolution looks poor.

Another artifact: 16:9 looks "better" than 4:3. Subjective perhaps, but it's not just cropping, my MBP gives me a wider angle shot of myself with more in the picture. Subconsciously, I probably also associate the form-factor with "HD".

On the flip-side the current docked chat window form-factor seems to fit 4:3 well.

> but we also don't have RTPsender settings to scale down the video yet,
> and we don't have the ability to change the capture resolution on the fly.

Right, though changing between 4:3 and 16:9 mid-call would be weird.

Still, I wish it looked its best with great hardware and a great network connection.

Might Hello, being part of the browser and all, perhaps be in a position to pick the best setting here based on a user's hardware and recent network connection speeds?
(Reporter)

Comment 7

2 years ago
Hi

> If I join the conversation with chromium, it works in 720p
Indeed I'm wrong it is 4:3 as you said

> I tried to force settings with this parameters in about:config
> media.navigator.video.default_height
> media.navigator.video.default_width
> but it does not work, video does not display.
Go here http://simpl.info/getusermedia/constraints/
clic HD, video is 640x480 (Should be HD)
change this in about:config => media.navigator.video.default_height=720
reload the page http://simpl.info/getusermedia/constraints/
clic HD
got "Actual video dimensions: 0x0px." and no video
(In reply to Alex from comment #7)
> Go here http://simpl.info/getusermedia/constraints/
> clic HD, video is 640x480 (Should be HD)
> change this in about:config => media.navigator.video.default_height=720
> reload the page http://simpl.info/getusermedia/constraints/
> clic HD
> got "Actual video dimensions: 0x0px." and no video

The second issue is very likely bug 1151628, which is fixed on FF38 and later (not 37).
(In reply to Alex from comment #7)
> Go here http://simpl.info/getusermedia/constraints/
> clic HD, video is 640x480 (Should be HD)
> change this in about:config => media.navigator.video.default_height=720
> reload the page http://simpl.info/getusermedia/constraints/
> clic HD
> got "Actual video dimensions: 0x0px." and no video

Alex, can you try with this link instead?

http://htmlpreview.github.io/?https://raw.githubusercontent.com/jan-ivar/samples/polyconstraints/src/content/getusermedia/resolution/index.html
Flags: needinfo?(alexis.krier)
(Reporter)

Comment 10

2 years ago
(In reply to Jan-Ivar Bruaroey [:jib] from comment #9)
> Alex, can you try with this link instead?
> 
> http://htmlpreview.github.io/?https://raw.githubusercontent.com/jan-ivar/
> samples/polyconstraints/src/content/getusermedia/resolution/index.html

Same thing, video is ok in 320 & 640 but when I clic on HD, webcam turns on but video is black

and when I change media.navigator.video.default_height to 720, nothing is working.

My FF is 37.0.2
Flags: needinfo?(alexis.krier)
Thanks, just had to eliminate possibilities.

I think Randell is right in comment 9. From [1] I see 1280x720x30fps is only available in MJPEG, which hits Bug 1151628. If you could try it in Firefox Beta 38 I bet it'll work.

Also, please try this workaround for FF37: http://jsfiddle.net/z2cj12k4 (it'll be 10 fps).

[1] http://www.linux-hardware-guide.com/2012-07-28-logitech-c525-hd-webcam
Flags: needinfo?(alexis.krier)
(Reporter)

Comment 12

2 years ago
(In reply to Jan-Ivar Bruaroey [:jib] from comment #11)
> Thanks, just had to eliminate possibilities.
> 
> I think Randell is right in comment 9. From [1] I see 1280x720x30fps is only
> available in MJPEG, which hits Bug 1151628. If you could try it in Firefox
> Beta 38 I bet it'll work.
> 
> Also, please try this workaround for FF37: http://jsfiddle.net/z2cj12k4
> (it'll be 10 fps).
> 
> [1] http://www.linux-hardware-guide.com/2012-07-28-logitech-c525-hd-webcam

Ok I understand the MJPEG problem.

with firefox 38 this:
http://htmlpreview.github.io/?https://raw.githubusercontent.com/jan-ivar/samples/polyconstraints/src/content/getusermedia/resolution/index.html
720p works !

also this http://simpl.info/getusermedia/constraints/ does NOT work with firefox 38, same problem

and this http://jsfiddle.net/z2cj12k4 does not work with firefox 37, it gives 640x480
Flags: needinfo?(alexis.krier)
(In reply to Alex from comment #12)
> with firefox 38 this:
> http://htmlpreview.github.io/?https://raw.githubusercontent.com/jan-ivar/
> samples/polyconstraints/src/content/getusermedia/resolution/index.html
> 720p works !

Great! I recommend closing this as a duplicate of Bug 1151628 then.

> also this http://simpl.info/getusermedia/constraints/ does NOT work with
> firefox 38, same problem

That web page is using non-standard Google-specific constraints that wont work with Firefox (Not sure why it's taking Google so long to accept my pull request).

> and this http://jsfiddle.net/z2cj12k4 does not work with firefox 37, it
> gives 640x480

Sorry, I made an error in it! I've now updated it, so please try again.
(Reporter)

Comment 14

2 years ago
(In reply to Jan-Ivar Bruaroey [:jib] from comment #13)
> Sorry, I made an error in it! I've now updated it, so please try again.

mmmm I still have 640x480 scale to 160x120 in the statistics frame
Hmm, ok here's a last attempt. One more time? http://jsfiddle.net/z2cj12k4
(Reporter)

Comment 16

2 years ago
(In reply to Jan-Ivar Bruaroey [:jib] from comment #15)
> Hmm, ok here's a last attempt. One more time? http://jsfiddle.net/z2cj12k4

not better I have no video and
NotFoundError: The object can not be found here.: line 0
OK sorry about that. Not sure why that's not working. In any case, FF38 is next week, so that should take care of the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151628
Whoops, forgot this was primarily a request for Hello to support HD. Re-opening.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Support for Hello/Loop has been discontinued.

https://support.mozilla.org/kb/hello-status

Hence closing the old bugs. Thank you for your support.
Status: REOPENED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → INCOMPLETE

Comment 20

7 months ago
There's a related bug I recently logged, which causes WebRTC to return a "could not satisfy constraints" error if you request anything other than 1280x720 when using a FaceTime HD camera on a new macbook pro:

https://bugzilla.mozilla.org/show_bug.cgi?id=1340826
You need to log in before you can comment on or make changes to this bug.