MX transactions not working

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: lsaunders, Assigned: Bango Platform Operations Center)

Tracking

Avenir
x86
Mac OS X
Points:
---

Details

Attachments

(4 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
Bango is now going direct to TEF and has deprecated Bluevia. 
Transaction are not currently being accepted through marketplace and Bango believes this is due to a marketplace configuration. Please see the attached screenshot for the error received.
(Reporter)

Comment 2

3 years ago
Created attachment 8581729 [details]
IMG_20150323_093530549_HDR copy.jpg

Comment 3

3 years ago
What conditions created that error? At what stage did that error occur? Are there logs or more information? That error is not a page controlled by Mozilla. 

If Bango believes its a problem from our configuration can we have some more details on what that might be?
Flags: needinfo?(lsaunders)
(Reporter)

Comment 4

3 years ago
Created attachment 8582418 [details]
First screen of Payment Flow
Flags: needinfo?(lsaunders)
(Reporter)

Comment 5

3 years ago
Created attachment 8582419 [details]
Screen 2.jpg
(Reporter)

Comment 6

3 years ago
Created attachment 8582421 [details]
Screen 3.jpg
(Reporter)

Comment 7

3 years ago
Above is the payment flow that Telefonica sees when they test. Bango says they do not control the error screen either and it is on Mozilla's side.

Comment 8

3 years ago
(In reply to lsaunders from comment #7)
> Above is the payment flow that Telefonica sees when they test. Bango says
> they do not control the error screen either and it is on Mozilla's side.

We are going to need some logs before we start to worry about where it is. It could be Telefonica, the provider or anywhere in between.
(Assignee)

Comment 9

3 years ago
Hi Andy,

We're looking into this now. We'll feedback when we have some more information for you.

Kind regards,

Max Pountney
Bango Platform Operations Center

Comment 10

3 years ago
Hi Andy,

Are you able to provide an device logs for the error? This would aid our investigation hugely. 

Kind regards,

Dan Hale
Bango Platform Operations Center
Flags: needinfo?(amckay)

Comment 11

3 years ago
(In reply to Bango NOC from comment #10)
> Hi Andy,
> 
> Are you able to provide an device logs for the error? This would aid our
> investigation hugely. 
> 
> Kind regards,
> 
> Dan Hale
> Bango Platform Operations Center

Nope, I don't have them either.
Flags: needinfo?(amckay)

Comment 12

3 years ago
Hi Lindsay,

As Andy is not in possession of the logs, are you able to provide any logging from your test?

Kind regards,

Dan Hale
Bango Platform Operations Center
Flags: needinfo?(lsaunders)
(Reporter)

Comment 13

3 years ago
Hi Dan, 

The issue was brought to Bango by TEF and tested in country by them. We do not have any logs and they would likely be the best source. I'll email my contact there, please also follow up on your end. 

Best, 
Lindsay
Flags: needinfo?(lsaunders)
(Assignee)

Comment 14

3 years ago
Thanks Lindsey,

We're in contact with Telefonica at the moment. We'll keep you updated.

Kind regards,

Max Pountney
Bango Platform Operations Center
(Assignee)

Comment 15

3 years ago
Dear Lindsay, Andy,

Following some coordinated testing with the operator, some discrepancies have been found in the operator's DNS configuration for Bango IP addresses. Consequently, the operator is not currently able to connect to the Bango website used for identification in this context.

We believe this to be the cause of the error reported here. The operator is scheduling a change to update the relevant DNS entry. We'll keep you up to date with the latest.


Kind regards,

Max Pountney
Bango Platform Operations Center

Comment 16

3 years ago
Thanks for the update.

Updated

3 years ago
Assignee: nobody → poc
Priority: -- → P1
(Assignee)

Comment 17

3 years ago
Dear Lindsay, Andy,

The change has been scheduled for 10am Mexico City time on the 7th. We'll be engaging with Telefonica in some testing after the change in order to confirm that the problem has been fixed.

We'll let you know how that goes.

Kind regards,

Max Pountney
Bango Platform Operations Center
(Assignee)

Comment 18

3 years ago
Dear Lindsay and Andy,

Please be advised that Telefonica's change has now gone live and identification requests are sucessfully being seen

We have also pushed through a successful test transaction

Are you able to clear your cache and then retry billing?

Kind Regards

Tanya
Bango Platform Operations Center
(Assignee)

Updated

3 years ago
Flags: needinfo?(amckay)

Comment 19

3 years ago
Marking as resolved fixed to see if Krupas QA team can test.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(amckay)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.