Closed Bug 1146442 Opened 5 years ago Closed 2 years ago

align-items: baseline not working with nested flex containers.

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52

People

(Reporter: philip, Assigned: dholbert)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36

Steps to reproduce:

View this demo:
http://codepen.io/anon/pen/KwJwRZ


Actual results:

The outer flex item on the left side (the <label>) is aligned to the baseline of the *second* line of text in the outer flex item on the right side.


Expected results:

The outer flex item on the left side (the <label>) should be aligned to the baseline of the *first* line of text in the outer flex item on the right side.
Component: Untriaged → Layout
OS: Mac OS X → All
Product: Firefox → Core
Hardware: x86 → All
Version: Firefox 38 → Trunk
Attached file testcase 1
Thanks for filing!

Here's a slightly tweaked version of the original testcase (as an attachment, for improved object-permanence).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed on Firefox 40.0.2 on OS X 10.10.5
FYI only: Similar demo (with slightly different coding) at P. Walton's Pen:

http://codepen.io/philipwalton/pen/vOOejZ
A simple workaround is to avoid having intermediate divs that are not in a flex layout.http://codepen.io/anon/pen/ZWwMyz
This is one of the few issues we have listed on https://github.com/philipwalton/flexbugs

Daniel, how hard would this be to fix?
Flags: needinfo?(dholbert)
Thanks for the heads-up. I don't think it should be too hard to fix. I'll take it & start working on it after I've finished fixing up our abspos-flex-child behavior (bug 1269045 & bug 1269046, which are the two pieces of bug 874718).
Assignee: nobody → dholbert
Flags: needinfo?(dholbert)
Flags: needinfo?(dholbert)
Any news here?
This appears to be working as expected in Firefox 56. Did this get fixed somewhere along the way?
Yes, this seems to be fixed.
Can someone from Mozilla confirm?
INFO: First good revision: 1e3af7fd9bfe507cdcff5e05a95c3a763617f25c
INFO: Last bad revision: ffb38910dcae79a05680bdb917ef93e69d6d3a8a
INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ffb38910dcae79a05680bdb917ef93e69d6d3a8a&tochange=1e3af7fd9bfe507cdcff5e05a95c3a763617f25c

Either bug 1306906 or bug 1307806 I'd think. Should be fixed in 52+.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Yeah, I also just tracked down the version where it was fixed and it definitely is 52. In 51.0.1 the problem still occurred.
Thanks!
(In reply to Ryan VanderMeulen [:RyanVM] from comment #10)
> Either bug 1306906 or bug 1307806 I'd think. Should be fixed in 52+.

bug 1307806 I'd say. Adding a dependency. Thanks!
Depends on: 1307806
Flags: needinfo?(dholbert)
You need to log in before you can comment on or make changes to this bug.