Closed Bug 1146464 Opened 5 years ago Closed 5 years ago

HTTP auth dialogs aren't shown

Categories

(Firefox for iOS :: Browser, defect)

All
iOS 8
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: wesj, Unassigned)

References

Details

Attachments

(1 file)

Trying to visit a site that requires auth just fails right now. We should show a username-password dialog like Safari does.
tracking-fennec: --- → ?
tracking-fennec: ? → +
Duplicate of this bug: 1147844
Component: General → Browser
OS: Mac OS X → iOS 8
Hardware: x86 → All
Summary: Http auth dialogs aren't shown → HTTP auth dialogs aren't shown
Let's make sure these dialogs are hooked into the password save/fill system.
Duplicate of this bug: 1113961
Attachment #8591943 - Flags: review?(bnicholson)
Comment on attachment 8591943 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/333

Looks OK to me with some comments. One thing that definitely needs to be fixed before landing is sorting out the localization strings, as mentioned.
Attachment #8591943 - Flags: review?(bnicholson) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Depends on: 1157251
You need to log in before you can comment on or make changes to this bug.