Closed Bug 1146520 Opened 5 years ago Closed 3 years ago

Add OS X shell builds to Treeherder

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jandem, Assigned: sfink)

References

(Blocks 1 open bug)

Details

Attachments

(5 files)

Attached patch PatchSplinter Review
We have Linux and Windows shell builds, would be great to have OS X shell builds too to avoid Mac-only bustage like bug 1146267.

This patch fixes some minor autospider issues I ran into locally, but to get it working in automation we'll probably need more magic that I don't understand :)
Attachment #8581847 - Flags: review?(sphink)
Attachment #8581847 - Flags: review?(sphink) → review+
Keywords: leave-open
Add them into buildbot-configs.
Attachment #8581880 - Flags: review?(bhearsum)
Assignee: nobody → sphink
Status: NEW → ASSIGNED
Comment on attachment 8581880 [details] [diff] [review]
Add ARM simulator spidermonkey builds on OSX

Review of attachment 8581880 [details] [diff] [review]:
-----------------------------------------------------------------

stampy stamp stamp stamp
Attachment #8581880 - Flags: review?(bhearsum) → review+
And hidden. Hopefully this is fixed ASAP so we're not wasting limited build slave resources on a permafailing job.
OSX builds removed for now with

https://hg.mozilla.org/build/buildbot-configs/rev/2f15edda43e5

They require clang, which needs to come from tooltool. But right now, the shell builds only pull from tooltool for Windows builds. I see no reason not to use the releng manifest for all platforms at this point.
Attachment #8583231 - Flags: review?(bhearsum)
And here's a followup I'm much less sure of. I'm activating this for both linux and osx because I can test it on my linux slave. I don't have an osx slave to test. I won't push this until it at least works on the slave.
Attachment #8583248 - Flags: review?(bhearsum)
Keywords: leave-open
Attachment #8583231 - Flags: review?(bhearsum) → review+
Attachment #8583248 - Flags: review?(bhearsum) → review+
Blocks: 1150618
Duplicate of this bug: 895208
Whoa. It's bizarre that I never landed all of this.

remote:   https://hg.mozilla.org/build/tools/rev/51042994ea9c
remote:   https://hg.mozilla.org/build/tools/rev/c4b2c07f4d7a
Attachment #8583231 - Flags: checkin+
Attachment #8583248 - Flags: checkin+
Duplicate of this bug: 1150338
Bleh. platform is "linux-debug". releng.manifest is under "linux32".
Attachment #8728550 - Flags: review?(terrence)
Attachment #8728550 - Flags: review?(terrence) → review+
Comment on attachment 8728550 [details] [diff] [review]
use the correct name for linux32 releng.manifest

https://hg.mozilla.org/build/tools/rev/f46262d5ecfc
Attachment #8728550 - Flags: checkin+
Looks like this is all working, though I'm not sure why it only covers the simulator. Well, we'll see what bhearsum says in bug 1275775.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.