Firefox for Android crashes when syncing

RESOLVED DUPLICATE of bug 964854

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 964854
3 years ago
2 years ago

People

(Reporter: 640kb, Unassigned)

Tracking

({crash})

36 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338
Firefox for Android

Steps to reproduce:

1. I entered mail and password for my sync-account. 
2. I entered mail, password and age for a new sync-account. 
3. the same as 1, but cellphone was rooted meanwhile.
The phone always was reseted to factory-defaults, only firefox was installed. Android is version 4.4.2.


Actual results:

Firefox crashed in all cases. It didn't sync. In Firefox -> properties -> Sync everything is grayed out, except 'sync now'.
https://crash-stats.mozilla.com/report/index/7bfaed87-35f1-48e3-a3f1-535232150319
https://crash-stats.mozilla.com/report/index/1d96a31e-1014-4a85-a68d-f7e0c2150320
https://crash-stats.mozilla.com/report/index/5b402725-6327-4afb-9492-970602150323
The last one was created after rooting device.


Expected results:

Firefox should sync my bookmarks.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ java.lang.IllegalStateException: stateLabelString must not be null at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getState(AndroidFxAccount.java) ]
Last Resolved: 2 years ago
Component: Untriaged → General
Keywords: crash
Product: Firefox → Firefox for Android
Resolution: --- → DUPLICATE
Version: 36 Branch → Firefox 36
Duplicate of bug: 964854
You need to log in before you can comment on or make changes to this bug.