[SHB][Cost Control / Usage] Data Limit 'Starting On' dropdown becomes unresponsive once scrolled to bottom

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], [SHB-enabled][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8581863 [details]
logcat_20150323_1217.txt

Description:
When a user is in the Cost Control app and attempts to set the date their data tracking will begin on, they will observe that on scrolling to the bottom of the day picker that appears that the UI can become very unresponsive: tapping a different day will result in (1) a partial highlight appearing, (2) a second checkmark appearing on screen, (3) nothing at all or a combination of the above. This occurs whether in the 'ftu' of the prescribed app, or when editting your data afterwards from the root of the app.

Repro Steps:
1) Update a Flame to 20150323010204
2) Open the Cost Control / Usage app.
3) Tap 'next' to access date setter page.
4) Tap the 'Starting On' dropdown field to begin scrollpicker.
5) Scroll to bottom of pop up.
6) Tap entries visible on screen.
7) Obseve responsiveness.

Actual:
UI for dropdown is unresponsive, doesn't appear to register taps or produces fractured UI.

Expected:
Tapped entries become checked; only one checked is allowed.


Environmental Variables:
------------------------------

Device: Flame 3.0
Build ID: 20150323010204
Gaia: 9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gecko: e730012260a4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
------------------------------

Device: Flame 2.2
BuildID: 20150323002504
Gaia: 7f367fc98ffdd183f21d2cdfe20556ab877ece34
Gecko: 3ea0eaeda353
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
============================
Issue DOES NOT REPRO on flame 2.1 devices
Results: Tapped entries become checked; only one checked is allowed.

Device: Flame 2.1
BuildID: 20150323001203
Gaia: 13c85d57f49b4bfd657ff674f2b530c141c94803
Gecko: aeabf85a622c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
------------------------------


Repro frequency: 9/10
See attached: 
video
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing], [SHB-enabled]
[Blocking Requested - why for this release]:
Functional regression of a supported feature.

Starting with 3.0? because this is 2.2 affected as well for SHB.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
Whiteboard: [3.0-Daily-Testing], [SHB-enabled] → [3.0-Daily-Testing], [SHB-enabled][systemsfe]
QA Contact: ychung
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150224201302
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: dfe95ed96563
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150224202353
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: dc07fc31d234
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: dc07fc31d234

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: dfe95ed96563

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dfe95ed96563&tochange=dc07fc31d234

possibly caused by 1134762
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
Benoit, can you take a look at this please? This might be caused by bug 1134762 but we are guessing here. There are 3 issues in the pushlog but they were all authored by you.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bgirard)
I wont have time until June, if it's urgent ni? Milan.
Flags: needinfo?(bgirard)
Duplicate of this bug: 1151099
Flags: needinfo?(milan)
Component: Gaia::Cost Control → Graphics: Layers
Product: Firefox OS → Core
Kats, can you take a look and see if it's bug 1134762?
Flags: needinfo?(milan) → needinfo?(bugmail.mozilla)
If the bug goes away if we set layers.low-precision-buffer preference to false, then it probably is bug 1134762.
Flags: needinfo?(ktucker)
Is there a way to reproduce this without having a SIM in the device? I have a SIM in my Nexus 4, but I can't reproduce the bug there (software home button is forced on there). On my Flame I don't have a SIM and can't get into the cost control app without one. I tried hacking up the app to just show the settings screen but that didn't work either, I kept getting more JS errors. If the costcontrol app authors can tell me what to do here that would be helpful.

Regardless I don't think bug 1134762 would have caused non-responsiveness. Glitchiness, possibly, but I didn't see any of that in the video from comment 0.
Flags: needinfo?(bugmail.mozilla)
Adding qa wanted to check if this still occurs when laysers.low-precision-buffer preference is set to false as stated in Comment 7.
Flags: needinfo?(ktucker)
Keywords: qawanted
Closing this as worksforme. We can no longer reproduce this issue on Flame 3.0 or on the Flame 2.2

The user can tap different selections without issue. 

Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150409002503 (Full Flash)(KK)(319mb)
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 0efd5cdbe224
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Please disregard Comment 10. I forgot to enable SHB. This issue still occurs.
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: WORKSFORME → ---
This issue does not occur anymore when I set the layers.low-precision-buffer preference to false.
Flags: needinfo?(milan)
Keywords: qawanted
Component: Graphics: Layers → Panning and Zooming
Flags: needinfo?(milan) → needinfo?(bugmail.mozilla)
See comment 8. Redirecting ni to listed module owner for the app.
Flags: needinfo?(bugmail.mozilla) → needinfo?(salva)
Latest Gaia on latest Gecko and the issue is not reproducing. Can you provide a video with the issue?
Flags: needinfo?(salva)
There's a video linked in the URL, but ni? reporter to repro on latest master and attach a new video. It may have been fixed already.
Flags: needinfo?(onelson)
(Reporter)

Comment 16

3 years ago
Issue DOES NOT REPRO on latest master [3.0] for flame devices
Results: Tapped entries become checked; only one checked is allowed.

--------------------------------------------------
Environmental Variables:
Device: Flame 3.0
BuildID: 20150410010202
Gaia: e768af6558957ddb0f6a9ce579ea41c3e3d0b203
Gecko: fec90cbfbaad
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
--------------------------------------------------

video- https://youtu.be/dsOhMrdR76k
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(onelson) → needinfo?(bugmail.mozilla)
Resolution: --- → WORKSFORME
Great, thanks. If this is reopened again please include video of regression.
Flags: needinfo?(bugmail.mozilla)
blocking-b2g: 3.0? → ---
You need to log in before you can comment on or make changes to this bug.