If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] browser_markupview_pagesize_02.js causes unsafe CPOW usage warnings

RESOLVED DUPLICATE of bug 1252099

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1252099
3 years ago
2 years ago

People

(Reporter: Kwan, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [unsafe-cpow-usage])

(Reporter)

Description

3 years ago
Mined from test logs

In browser/devtools/markupview/test/browser_markupview_pagesize_02.js:

function* assertAllNodesAreVisible(inspector) {
  let container = yield getContainerForSelector("ul", inspector);
  ok(!container.elt.querySelector("button"), "All nodes button isn't here anymore");
  is(container.children.childNodes.length, getNode("ul").children.length); <- Causes CPOW warning
}
When bug 1146566 is resolved, markupview tests will have access to the frame-script-utils.js frame-script which exposes a useful devtools:test:getElementInfo message listener which can be used to avoid using CPOWs this test.
Depends on: 1146566

Updated

3 years ago
Blocks: 984139
tracking-e10s: ? → m8+
tracking-e10s: m8+ → ---
Whiteboard: [unsafe-cpow-usage]
This is test only.
tracking-e10s: --- → +
Inspector bug triage. Filter on CLIMBING SHOES

Fixed by Bug 1252099.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1252099
You need to log in before you can comment on or make changes to this bug.