Closed Bug 1146609 Opened 7 years ago Closed 7 years ago

[Fennec][B2G] Multitouch not working on maps.google.com

Categories

(Web Compatibility :: Mobile, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1150284

People

(Reporter: gerard-majax, Unassigned)

References

()

Details

(Whiteboard: [country-all] [js] )

STR:
 0. Load maps.google.com
 1. Try to zoom with two fingers

Expected:
 Should zoom

Actual:
 Do not zoom

This is working properly in HERE Maps and Gallery.
I've noticed this too. Multi-touch definitely works, so I'm wondering if this is down to google using non-standard methods for pinching and spreading.
Any idea what we would look at ?
Flags: needinfo?(bugmail.mozilla)
My first step would be to check Fennec to see if it works there (it did last time I checked) and if so try some UA spoofing to see if they're serving different content to FxOS and Fennec.
Flags: needinfo?(bugmail.mozilla)
It does not work on Fennec Nightly, I just checked. What's the next thing you would check?
Flags: needinfo?(bugmail.mozilla)
I would close this bug as invalid (or move it to tech evangelism). If Google maps is explicitly preventing the behavior they have a right to do that and there's not much we can do from the technical side.
Flags: needinfo?(bugmail.mozilla)
Since we are targeting many Mozillians to be using these devices, and Google Maps is great for public transit across the world, let's try and get this addressed.
Component: General → Mobile
Product: Firefox OS → Tech Evangelism
Version: unspecified → Trunk
Summary: [Shinano][Aries] Multitouch not working on maps.google.com → [Fennec][B2G] Multitouch not working on maps.google.com
Interesting, pinch-to-zoom works in Beta and Release, but not Nightly.
Probably not far from this bug.
Bug 990767
See Also: → 990767
Whiteboard: [country-all] [js]
Based on comment 7 and bug 1150284, this looks to be a regression in Gecko. Hopefully the regression window from that bug provide some insight.
See Also: → 1150284
Is this a dupe of bug 1150284 (which was just fixed)? The STR/actual-results/expected-results look the same.
Seems a dup
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150284
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.