Closed Bug 1146626 Opened 5 years ago Closed 5 years ago

Async scrolling reftests fail when not using e10s

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
e10s - ---
firefox39 --- fixed

People

(Reporter: mstange, Assigned: mstange)

References

Details

Attachments

(1 file, 1 obsolete file)

Running
> mach reftest --setpref layers.async-pan-zoom.enabled=true layout/reftests/async-scrolling
on Mac results in many failures, because we're apparently not taking a new snapshot of the layer tree after we've adjusted the async scroll offsets.

I'm attaching a patch I wrote 5 months ago, and I've confirmed that it fixes it, but I don't know whether the "UpdateWholeCanvasForInvalidation" that it adds is in the right place.
Attached patch patch (obsolete) — Splinter Review
Hopefully this will fix the windows async-scrolling reftest failures as well that I get when I do a try push with APZ enabled, e.g. https://treeherder.mozilla.org/#/jobs?repo=try&revision=cc63db12dafb
Attached patch patchSplinter Review
Still not sure if I've found the right place to make the change.
Attachment #8581985 - Attachment is obsolete: true
Attachment #8583557 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/77f34f458d02
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.