[Session Restore] FF can't restore session after a crash

RESOLVED DUPLICATE of bug 1146052

Status

()

RESOLVED DUPLICATE of bug 1146052
4 years ago
4 years ago

People

(Reporter: vicenzi.alexandre, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150322030216

Steps to reproduce:

Surfing on the web.
FF crash and restart.


Actual results:

Session restore opens and ask if I want to restore. Kind OK.
But, there's no page to restore.

FF can't remember last session, but it remember that there's a crash and something must be done.


Expected results:

Remember all pages opened before crash and restore them.

E10S is disabled.
This happened more than once, and with old versions too.
(Reporter)

Updated

4 years ago
Component: Untriaged → Session Restore
I've been seeing this a lot lately. It happened to me today on my laptop and happened multiple times on another one. STR seemed to be to have a debugger attached, then forcefully terminate Firefox with the debugger. The next time Firefox starts, the "well, this was embarrassing" prompt is displayed but the tab list is empty.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: firefox-backlog?
OS: Linux → All
Hardware: x86_64 → All
I have seen this a ton in the last week.
That's fixed already, sorry for any trouble this caused.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146052
Flags: firefox-backlog?
You need to log in before you can comment on or make changes to this bug.