bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Flame][Browser]The icon size can't auto fit the screen width after switching between landscape mode and portrait mode.

RESOLVED DUPLICATE of bug 1146825

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 1146825
3 years ago
3 years ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

316.91 KB, text/plain
Details
2.42 MB, video/mp4
Details
(Reporter)

Description

3 years ago
Created attachment 8582299 [details]
logcat_0431.txt

[1.Description]:
[Flame v2.2 & v3.0][Browser]The apps in search result  in search result will not auto zoom out to fit the screen width after switching from landscape to portrait mode.
Found time:04:31
See attachment:video.MP4 and logcat_0431.txt

[2.Testing Steps]: 
1. Launch Browser.
2. Change to landscape mode.
3. Tap search bar and input some words.(such as "h")
4. Slide down and observe the apps in search result.
5. Change back to portrait mode.
6. Observe the apps in search result.

[3.Expected Result]: 
4&6. The apps should auto zoom out to fit the screen width and nothing should overlap.

[4.Actual Result]: 
4. The apps name overlaped with the line.
6. The apps are shown with incorrect size and overlap with the line.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.193421
Firmware Date          Mon Mar 23 19:34:34 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
Search something at portrait mode, and then change to landscape, the apps icon in search result can't auto fit the current orientation.
(Reporter)

Comment 1

3 years ago
Created attachment 8582300 [details]
video.MP4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Dupe of bug 1146825?
(Reporter)

Comment 3

3 years ago
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Dupe of bug 1146825?

Yes, duplicate of bug 1146825
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146825
You need to log in before you can comment on or make changes to this bug.