[Search] The zoomed and cut app icons after rotating phone to portrait mode from landscape mode

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: hcheng, Assigned: daleharvey)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

* Description:
If I use search app at landscape mode, the app icons do not change to correct ones after rotating phone to portrait mode.

* STR:
1. Enter a landscape app (Browser, Gallery, Etc)
2. Tap the rocketbar and begin typing in search app (Example: Goo)
3. after search results are shown, rotate phone to portrait mode

* Actual result:
The app icons remain larger size but cut

* Expected result:
The app icons become correct size.

* Env:
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0
Nominate 2.2 blocker since the experience is not good.
blocking-b2g: --- → 2.2?
See Also: → 1130587
Whiteboard: [systemsfe]
blocking-b2g: 2.2? → 2.2+
Is this a regression?
Keywords: qawanted
Assignee

Comment 3

4 years ago
Taking this, a regression window would be handy
Assignee: nobody → dale
QA Contact: jmercado
Ths issue does occur on Flame 3.0 and 2.2 but does not occur on Flame 2.1.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150323164830
Gaia: efebbafd12fc42ddcd378948b683a51106517660
Gecko: 235a9cb26548
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150324071928
Gaia: 7024dd4c7a7c3616dc8f9f908759f00abc0deddd
Gecko: cb4856ecd781
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1
BuildID: 20150324053633
Gaia: b8ae0df34362420fe4a9c90effa5247a1f5c844d
Gecko: 2a05cd42088
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedregression
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Bug 1117967 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150204133222
Gaia: f0ec475d0708442a00aa4e62792ccb6b32f8a52a
Gecko: 6a59bfc39c20
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150204135220
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: aca61d9d1067
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: f0ec475d0708442a00aa4e62792ccb6b32f8a52a
Gecko: aca61d9d1067

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 6a59bfc39c20

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/f0ec475d0708442a00aa4e62792ccb6b32f8a52a...2b83a6d5d1185a438b5bbd287497ac2743b501db
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Ben, can you please take a look at this? This might have been caused by the work done for bug 1117967.
Blocks: 1117967
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bfrancis)

Updated

4 years ago
Duplicate of this bug: 1146819
Assignee

Comment 9

4 years ago
Comment on attachment 8583419 [details] [review]
[gaia] daleharvey:1146825 > mozilla-b2g:master

So most of this code change is just renaming the windowWidth variable, however once I fixed that icons we incorrectly placed due to 
 
  |width: calc(100% / 3);| 

Which I am surprised works for 4 columns icons at all

  |tile.style.width = (this.grid.layout.gridItemWidth / scale) + 'px';|

takes into account the scale so an 80px icon gets set to ~126px before it gets scaled back down to 80px with the existing transform.
Attachment #8583419 - Flags: review?(kgrandon)
Assignee

Updated

4 years ago
Duplicate of this bug: 1130587
Comment on attachment 8583419 [details] [review]
[gaia] daleharvey:1146825 > mozilla-b2g:master

Looks good. I think we can go with this for now. Thanks!
Attachment #8583419 - Flags: review?(kgrandon) → review+
Target Milestone: --- → 2.2 S9 (3apr)
This problem is verified pass on latest build of Flame 3.0.
Actual result: After search results are shown, rotated phone back to portrait mode, the app icons return to correct size and is not cut off.
See attachment: VIDEO1239_Compress.MP4
Rate: 0/5
Device: Flame 3.0 (Pass)
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.042104
Firmware Date          Sun Mar 29 04:21:16 EDT 2015
Bootloader             L1TC000118D0
Leaving verifyme keyword for 2.2 uplift/verification.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Dale, could you please uplift to 2.2? Thank you.
Flags: needinfo?(dale)
This patch has broken the appearance of collapsed groups on startup, please don't uplift until we have a fix.
Depends on: 1149100
Assignee

Comment 16

4 years ago
Comment on attachment 8583419 [details] [review]
[gaia] daleharvey:1146825 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1117967
[User impact] if declined: Poor user experience for search app in landscape mode
[Testing completed]: Layout issue manually verified
[Risk to taking this patch] (and alternatives if risky): Is baked on master, regression found and ready to be uplifed @ https://bugzilla.mozilla.org/show_bug.cgi?id=1149100
[String changes made]:
Flags: needinfo?(dale)
Attachment #8583419 - Flags: approval-gaia-v2.2?
Assignee

Updated

4 years ago
Duplicate of this bug: 1149460
Attachment #8583419 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Build ID               20150331162505
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/88e0e00cd64e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150331.200333
Firmware Date          Tue Mar 31 20:03:44 EDT 2015
Bootloader             L1TC100118D0
clearing NI and close this bug
Status: RESOLVED → VERIFIED
Flags: needinfo?(bfrancis)
Per Comment 13 & Comment 19,clear "verifyme".
Keywords: verifyme
Depends on: 1150835
You need to log in before you can comment on or make changes to this bug.