Closed Bug 1146829 Opened 5 years ago Closed 5 years ago

[RTL][Settings]The "+" symbol is shown at right side of phone number in SIM manager view.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: yulan.zhu, Assigned: eragonj)

References

Details

Attachments

(3 files)

[1.Description]:
[RTL][v2.2&v3.0][Settings]Insert one or two sim cards to device, the "+" symbol is shown at right side of phone number in SIM manager view.
See attachment:Screenshot_phone number.png

[2.Testing Steps]: 
1.Insert one or two SIM card to device.
2.Launch Settings and enter "SIM Manager" view.
3.Observe the phone number.

[3.Expected Result]: 
3.The "+" symbole should be shown at left side of phone number.

[4.Actual Result]: 
3..The "+" symbol is shown at right side of phone number.

[5.Reproduction build]: 
Flame 2.2 build (Affected): 
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
uild ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.193421
Firmware Date          Mon Mar 23 19:34:34 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
blocking-b2g: --- → 2.2?
Priority: -- → P2
Assignee: nobody → ejchen
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8582840 [details] [review]
[gaia] EragonJ:bug-1146829 > mozilla-b2g:master

Arthur, this bug looks quite the same with bug 1142924 but happened in SimManagers. For this patch, I used the same way (<bdi>) to fix the bug. Can you help me check it ? Thanks !
Attachment #8582840 - Flags: review?(arthur.chen)
Comment on attachment 8582840 [details] [review]
[gaia] EragonJ:bug-1146829 > mozilla-b2g:master

r=me, thanks!
Attachment #8582840 - Flags: review?(arthur.chen) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8582840 [details] [review]
[gaia] EragonJ:bug-1146829 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: they will see the "+" in a wrong order.
[Testing completed]: did manual tests
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8582840 - Flags: approval-gaia-v2.2?
Attachment #8582840 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15578/
Flags: in-moztrap+
According to the steps in Comment0, this issue is verified pass on latest Flame 2.2 and Flame 3.0 build.
See attachment: Verify1_Flame2.2&3.0_Pass.png
Reproducing rate:0/10

Flame 2.2 build (Affected):
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 19:26:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.