Closed Bug 1146831 Opened 5 years ago Closed 5 years ago

[Flame][Built-in&System Keyboard]Can't invoke the paste button.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: fan.luo, Assigned: mtseng)

Details

Attachments

(5 files)

Attached video video.mp4
[1.Description]:
[Flame][v2.2 & v3.0][Built-in&System Keyboard] User can not invoke Past button via long tapping the blank line above strings.
Found time:17:27
Attchment:logcat_1727.txt & video.mp4

[2.Testing Steps]:
Prerequisite: You have already added an email account.
1.Open Email app.
2.Tap compose icon.
3.Input an Email address into field and then copy it.
4.Tap cc field and paste strings.
5.Long tap the black line above the "--"

[3.Expected Result]: 
5.You can invoke invoke paste button.

[4.Actual Result]: 
5.You can't invoke paste button.

[5.Reproduction build]: 
Flame 2.2(Affected)
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Affected)
Build ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.193421
Firmware Date          Mon Mar 23 19:34:34 EDT 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
a.Other text field also exist(Message,Contacts.....).
b.User can invoke past bubble in blank text field.
c.Andriod phone can invoke paste bubble in the same situation.
Attached file logcat_1727.txt
C/P related
Flags: needinfo?(gchang)
NI EPM to see if this is 2.2 blocker.
blocking-b2g: --- → 2.2?
Flags: needinfo?(gchang) → needinfo?(hochang)
QA Whiteboard: [COM=Text Selection]
Hi Peter, can you have a look? This seems Gecko issue?
Flags: needinfo?(hochang) → needinfo?(pchang)
Norry, I can't open the attached video file. Could you reupload again?
Flags: needinfo?(pchang) → needinfo?(fan.luo)
Peter, you can try to download the file to local, and play it, playing in browser seems to be faulty
Flags: needinfo?(fan.luo)
howie, I think this is not related to keyboard app but more likely related to email app, like bug 1142316.
Flags: needinfo?(hochang)
Hi Dylan, can this dup to bug 1142316?
Component: Gaia::Keyboard → Gaia::E-Mail
Flags: needinfo?(hochang) → needinfo?(doliver)
This bug deals with the compose area, which uses a contenteditable field, so it is closer to bug 1110917, but a different behavior, so seems good to track as a separate bug. However, as with bug 1110917 comment 2, will ask Core, Selection for to take a look.

Email itself is not in control of the placement of the copy/paste menu, but happy to work on an HTML/CSS fix in email if there is something extra we need to do other than just enable text selection.

The body area is a contenteditable area, which might be contributing to the issue. It would be difficult to move away from that though for email composition.
Component: Gaia::E-Mail → Selection
Flags: needinfo?(doliver)
Product: Firefox OS → Core
Comment on attachment 8585863 [details] [review]
[gaia] mephisto41:bug1146831 > mozilla-b2g:master

If line is empty then a empty text node would be created. Then long tap would select from this empty text node to next <br> node. So we skip text node creation if text is empty.
Attachment #8585863 - Flags: review?(jrburke)
Assignee: nobody → mtseng
Status: NEW → ASSIGNED
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8585863 [details] [review]
[gaia] mephisto41:bug1146831 > mozilla-b2g:master

This seemed to help. I was able to get the paste menu to show up, sometimes it would also just auto paste depending on the tap combo. Confirmed it restores a draft correctly too.

However, there were still times where it was hard to activate the paste menu. This change improves things though, so we should land it.
Attachment #8585863 - Flags: review?(jrburke) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Updating target component to help autolander
Component: Selection → Gaia::E-Mail
Keywords: checkin-needed
Product: Core → Firefox OS
https://github.com/mozilla-b2g/gaia/pull/29242

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Autolander seems to be stuck, so manually merged in gaia master:
https://github.com/mozilla-b2g/gaia/commit/9fcf831b414566917c51f8d96622974424533cfb

from pull request:
https://github.com/mozilla-b2g/gaia/pull/29242
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8585863 [details] [review]
[gaia] mephisto41:bug1146831 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: User unable to trigger paste button.
[Testing completed]: On master.
[Risk to taking this patch] (and alternatives if risky): low risk, simple one line fix.
[String changes made]: None
Attachment #8585863 - Flags: approval-gaia-v2.2?
Attachment #8585863 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Attached video VIDEO0343_Compress.MP4
This issue still exist on flame 2.2 &3.0
Flame 3.0:
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Flame 2.2:
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate          5/5
Happen time             11:11
newlog                  logcat_1111.txt
Flags: needinfo?(echang)
QA Whiteboard: [COM=Text Selection] → [COM=Text Selection][MGSEI-Triage+]
Attached file logcat_1111.txt
Flags: needinfo?(echang) → needinfo?(gchang)
User should tap the blue caret to invoke paste icon. 
It can work on below build.
Build ID               20150408162503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ab8a3ae0fc3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flags: needinfo?(gchang)
Accordding comment 21,I tap the blue caret to invoke paste icon. It can work on below build.
Verified successfully on flame 2.2&3.0:
Flame 2.2 
Build ID               20150409002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0efd5cdbe224
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flame 3.0
Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.