[Flame][Dialer]During importing contacts, go back to contact A's call Information view, the screen will flash.

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8582319 [details]
logcat_1627.txt

[1.Description]:
[Flame][v2.2&v3.0][Dialer] Enter call Information view from call log screen, switch to Contacts tab and import contacts, during importing contacts, go back to the contact A's call Information view, the screen will flash.
See attachment: logcat_1627.txt & Video2.MP4
Found at: 16:27

[2.Testing Steps]: 
Precondition: 1. You have inserted a SIM card with some contacts in it;  2. There's a known contact (contact A) call log in phone.
1. Launch Phone app and switch to Call log view.
2. Long press the contact A's call log and select "Call Information".
3. Tap Contacts tab and tap settings icon.
4. Tap "Import Contacts" and select SIM card.
5. During importing, tap call log tab.

[3.Expected Result]: 
5. Go back to the call Information view, the screen should not flash.

[4.Actual Result]: 
5. Go back to the call Information view, the screen will flash.

[5.Reproduction build]: 
Flame 2.2 build: (affected)
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: (affected)
Build ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.193421
Firmware Date          Mon Mar 23 19:34:34 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
During importing contacts form Memory card/Gmail/Outlook, this problem also can be repro.
(Reporter)

Comment 1

4 years ago
Created attachment 8582321 [details]
Video2.MP4
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
This might be a fallout of bug 1112577. QA wanted to check the 2.1 branch. If it does not repro there, please check [1]. If [1] also doesn't repro, please check [2].

[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk/2015/02/2015-02-13-16-02-29/
[2] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk/2015/02/2015-02-15-16-03-30/
Keywords: qawanted
This issue does NOT reproduce on latest 2.1, does NOT repro on [1], and does NOT repro on [2].

Looks like bug 1112577 isn't the cause of the issue.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(ktucker)
Keywords: qawanted → regression
This looks bad but seems to be edge case. Not requesting a window here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]: Regression from 2.1 which can hurt the first time experience.
blocking-b2g: --- → 2.2?
In my opinion, this is not important enough to be a blocker. It's very much an edge case that a user is unlikely to run into, and isn't actually broken functionality, just a bit ugly.

Should this become a blocker, here are my thoughts:

Since we're almost at 2.2 FC, I think that fixing this properly is too much work and too risky. We already have bug 1144537 filed for fixing this properly, and we'll get to that for 3.0. So for now, my recommendation is this:

When we get a 'contactchange' event, we set a timer of 0.5 s or so, and if we get another 'contactchange' event before that one is fired, we restart the timer. Once all of the contacts are imported, the last timer should actually fire, and we update the call info page then.

This is pretty ugly, but it's an easy and less risky fix that we can back out of 3.0 once we've dealt with it properly.
CC'ing Steve and Oleg as we may need their help fixing this if it is given blocker status.
triage: the symptom is really bad though this is not a very frequent path. major regression.
blocking-b2g: 2.2? → 2.2+
Steve, Oleg, can one of you take this?
Flags: needinfo?(schung)
Flags: needinfo?(azasypkin)
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #9)
> Steve, Oleg, can one of you take this?

Hey Doug,

Just a reminder that I'm OOO on Monday, I can take this the day after tomorrow if Oleg doesn't.
triage: 
removed the blocking status and NIs. 
after further discussion, triage decided not to block at this corner case.
blocking-b2g: 2.2+ → ---
Flags: needinfo?(schung)
Flags: needinfo?(azasypkin)
[Tracking Requested - why for this release]: Regression which can confuse an end-user.
tracking-b2g: --- → backlog
Per comms triage
Priority: -- → P2

Comment 14

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.