Implement throttling network speed in dev tools

RESOLVED DUPLICATE of bug 1110207

Status

--
enhancement
RESOLVED DUPLICATE of bug 1110207
4 years ago
4 months ago

People

(Reporter: ockham, Unassigned)

Tracking

36 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150220131007

Steps to reproduce:

I'm using Firefox for web development. I'm working on a website's 'loading' states -- like when a web page is still fetching data from the server, and I want to communicate that visually to the user by e.g. an animation.


Actual results:

FF doesn't have an option to temporarily throttle network speed.


Expected results:

To me as a web developer, it would be very useful to be able to throttle network speed, as e.g. Chromium is able to.

Updated

4 years ago
Component: Untriaged → Developer Tools: Netmonitor

Updated

4 years ago
Severity: normal → enhancement
Summary: Throttle network speed → Implement throttling network speed in dev tools
Thanks for the report!  I would suggest adding a comment in the duplicate bug 1110207 with your perspective of the value of this, since the current discussion is a bit mixed so far.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1110207

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.