Add GATT support to Bluetooth daemon

RESOLVED DUPLICATE of bug 1115653

Status

Firefox OS
Bluetooth
RESOLVED DUPLICATE of bug 1115653
3 years ago
3 years ago

People

(Reporter: tzimmermann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We need GATT support in the Bluetooth daemon in v3.0 and later.
Hi Jocelyn,

I started writing some patches for GATT support in the Bluetooth daemon. What's the minimum Android version? 19 (aka Kitkat)? And do we already support server-side APIs or just client-side APIs? Thanks.
Flags: needinfo?(joliu)
Hi Thomas,

Yes, our current implementation is based on Kitkat instead of JB.
After finish client-side API recently, we will soon move on to server-side APIs(Please see Stage 4 and 5 in [1]).
Support server-side APIs in |GattHALInterface| will also start recently before we start to implement server-side WebAPI.

[1] latest GATT implementation plan: https://docs.google.com/a/mozilla.com/document/d/1g5DpJGCGXJcHfcEVly1om8QRi5xoqhVXdpInQmtNJOc

Thanks,
Jocelyn
Flags: needinfo?(joliu)
Just remember that I opened Bug1115653 for daemon support part during planing.
You may choose to mark one as duplicate.

Our plan on support for android version was,
  JB: can build, but don't have GATT support
  Kitkat: GATT support
  L: GATT support (this will happen later after we have the first implementation based Kitkat, but should be done before v3.)

Thanks,
Jocelyn
Thanks for the info. I'm closing this bug as duplicate.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115653
Hi

> Support server-side APIs in |GattHALInterface| will also start recently
> before we start to implement server-side WebAPI.

Just a warning. The HAL backend is deprecated and will *very likely* not be available in v3.0. So you'll waste a lot of time with code that will be removed soon. I suggest to spend the time on daemon support instead.
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #5)
> Hi
> 
> > Support server-side APIs in |GattHALInterface| will also start recently
> > before we start to implement server-side WebAPI.
> 
> Just a warning. The HAL backend is deprecated and will *very likely* not be
> available in v3.0. So you'll waste a lot of time with code that will be
> removed soon. I suggest to spend the time on daemon support instead.

Yes, I understood that, thanks for the warning.

But it means we will need to switch to daemon and have full GATT support in daemon before we actually can work on GATT server-side API.
I was just worried me or Bruce might not be able to do this on time without blocking server-api implementation when I planed it.
And add server-side in HAL based on what we already done for client-side looks a lot easier for me.

Of course, if you jump in on this part, that would be a different story. ;)
I won't promise anything, but I added a bluetoothd branch with GATT callbacks to bug 1115653. It's a start towards full support.
You need to log in before you can comment on or make changes to this bug.