[l10n][Settings] Arabic: The string "App usage by region" is truncated

VERIFIED WORKSFORME

Status

Mozilla Localizations
ar / Arabic
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8582594 [details]
ArabicTruncation.png

Description:
In Settings > Improve Firefox OS, the string "App usage by region" is truncated in Arabic.

Repro Steps:
1) Update a Flame to 20150324010202.
2) Set the device language in Arabic under Settings > Language.
3) Go to Settings > Improve Firefox OS.
4) Observe the string "App usage by region".

Actual:
The "App usage by region" string is truncated in test language.

Expected:
The "App usage by region" string is NOT truncated and displayed properly in test language.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150324010202
Gaia: efebbafd12fc42ddcd378948b683a51106517660
Gecko: 840cfd5bc971
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Comment 1

3 years ago
This issue also reproduces on Flame 2.2.

Result: The "App usage by region" string is truncated in test language.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150324002504
Gaia: 014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gecko: 7a9f2a248e57
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------
The "App usage by region" string" does NOT exist on Flame 2.1.

Device: Flame 2.1 (KK, 319mb, shallow flash)
Build ID: 20150324053633
Gaia: b8ae0df34362420fe4a9c90effa5247a1f5c844d
Gecko: 2a05cd42088b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1155575

Comment 3

3 years ago
Created attachment 8598483 [details]
2015-04-27-17-09-35.png

Set system language to Serbian Latin ,this issue exist on flame 2.2:

Build ID               20150427002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.040119
Firmware Date          Mon Apr 27 04:01:31 EDT 2015
Bootloader             L1TC000118D0
Note:There is no this function on Flame 2.1

Comment 4

3 years ago
Created attachment 8615110 [details]
verify_v2.2_Arabic_pass.png

This issue can not be reproduced on latest user build of Flame 2.2 by STRs in comment 0.
Result: When system language set as Arabic and Serbian Latin, the "App usage by region" string is NOT truncated and displayed properly in test language.
See attachment: verify_v2.2_Arabic_pass.png & verify_v2.2_sr-Latn_pass.png
Rate:0/3

Device: Flame 2.2 user (unaffected)
Build ID               20150603162502
Gaia Revision          b92e782ca12397acc3eb52f2e237522c0213f4e0
Gaia Date              2015-06-03 21:02:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/74421c778aff
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.194942
Firmware Date          Wed Jun  3 19:49:55 EDT 2015
Bootloader             L1TC000118D0

Comment 5

3 years ago
Created attachment 8615111 [details]
verify_v2.2_sr-Latn_pass.png

Comment 6

3 years ago
This issue also can not be reproduced on latest user build of Flame 3.0 by STRs in comment 0.
Result: When system language set as Arabic and Serbian Latin, the "App usage by region" string is NOT truncated and displayed properly in test language.
Rate:0/3

Devie: Flame 3.0 user (unaffected)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.192923
Firmware Date          Wed Jun  3 19:29:35 EDT 2015
Bootloader             L1TC000118D0

------------------------------------------------
If anyone can repro it, reopen again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Resolution: --- → WORKSFORME

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.