Fetching tabzilla over http redirects to https on mozlla.org

RESOLVED FIXED

Status

Websites
Tabzilla
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: andershol, Unassigned)

Tracking

Production

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
If I fetch the tabzilla css via https it works as expected:

$ wget -O /dev/null https://mozorg.cdn.mozilla.net/media/css/tabzilla-min.css
--2015-03-24 21:19:06--  https://mozorg.cdn.mozilla.net/media/css/tabzilla-min.css
Resolving mozorg.cdn.mozilla.net (mozorg.cdn.mozilla.net)... 68.232.34.191
Connecting to mozorg.cdn.mozilla.net (mozorg.cdn.mozilla.net)|68.232.34.191|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 22517 (22K) [text/css]

But if I fetch it via http, I get redirected to mozilla.org via https which is bad since the load of css will block first paint on sites using tabzilla:

$ wget -O /dev/null http://mozorg.cdn.mozilla.net/media/css/tabzilla-min.css
--2015-03-24 21:23:18--  http://mozorg.cdn.mozilla.net/media/css/tabzilla-min.css
Resolving mozorg.cdn.mozilla.net (mozorg.cdn.mozilla.net)... 68.232.34.191
Connecting to mozorg.cdn.mozilla.net (mozorg.cdn.mozilla.net)|68.232.34.191|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.mozilla.org/media/css/tabzilla-min.css [following]
--2015-03-24 21:23:20--  https://www.mozilla.org/media/css/tabzilla-min.css
Resolving www.mozilla.org (www.mozilla.org)... 63.245.217.105
Connecting to www.mozilla.org (www.mozilla.org)|63.245.217.105|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 22517 (22K) [text/css]

There is a similar problem for http://mozorg.cdn.mozilla.net/tabzilla/tabzilla.js . This is supposed to do a single redirect to add the locale, which it does when loaded over https, but it does two when loaded over http.

Updated

3 years ago
Component: Bedrock → Tabzilla
Product: www.mozilla.org → Websites
This issue could be fixed in some way but mozilla.org and CDN are only serving content via https since last July (Bug 796109) so I think the Tabzilla document [1] just needs to be updated to recommend using https, not protocol relative URLs.

[1] http://bedrock.readthedocs.org/en/latest/tabzilla.html
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 8583250 [details] [review]
pull request to update the Tabzilla document

Comment 3

3 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/ea7d1a6b3119e3dd5dca3d7d9b9d933ebd48cd4e
Update Tabzilla document to recommend using https, not protocol relative URLs

Part of Bug 1147139. mozilla.org is no longer serving content via http.

Comment 4

3 years ago
Fixed by commit in comment #3
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.