Partner repack changes for Yahoo -- US intl search URL and start page URL update

RESOLVED FIXED

Status

Release Engineering
Releases: Custom Builds
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Sneha Datla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8582680 [details] [diff] [review]
repack_config_changes_for_yahoo.diff

Hi, 

We found that the search URL and start page URL are outdated and have updated them for US intl. Please review and integrate the changes. 

Overview of changes:

1. Search URL changed to be "https://search.yahoo.com/yhs/search?ei=UTF-8&fr=chrf-yff37&hspart=mozilla&hsimp=yhs-002&p={query}" instead of "https://search.yahoo.com/search?ei=UTF-8&fr=chrf-yff37&p={query}"

2. Browser startup homepage changed to be "about:newtab" instead of 
"https://search.yahoo.com/firefox/?fr=sfp-yff37"

Thanks,
Sneha
Attachment #8582680 - Flags: review+
Comment on attachment 8582680 [details] [diff] [review]
repack_config_changes_for_yahoo.diff

Changing to r-, the patch doesn't apply.
Attachment #8582680 - Flags: review+ → review-
Flags: needinfo?(sdat27)
(Reporter)

Comment 2

3 years ago
Created attachment 8583370 [details] [diff] [review]
Search & Start page URL change patch #2

Can you check if you are able to apply this patch? I added it as an attachment.

Thanks,
Sneha
(In reply to Sneha Datla from comment #2)

> Can you check if you are able to apply this patch? I added it as an
> attachment.

It still didn't apply.  Have you done 'hg pull -u' recently?
Flags: needinfo?(sdat27)
(Reporter)

Comment 4

3 years ago
I followed the steps listed here https://wiki.mozilla.org/Partnering/Repacks/Submitting_Changes in 'Creating a Patch' section.

I did 'hg pull && hg update -r default' before making my changes.
Comment on attachment 8582680 [details] [diff] [review]
repack_config_changes_for_yahoo.diff

https://hg.mozilla.org/build/partner-repacks/rev/1452264ae92e

The problem was differing line endings in the files, I fixed that and pushed.
Attachment #8582680 - Flags: review- → review+
actual yahoo patch

https://hg.mozilla.org/build/partner-repacks/rev/df17e070d04e
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.