Intermittent hazard build failure with "make[3]: *** [/builds/slave/l64-br-haz_m-in_dep-0000000000/build/obj-opt-js/js/src/jsautokw.h] Error 127"

RESOLVED DUPLICATE of bug 1146738

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1146738
3 years ago
3 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

39 Branch
x86_64
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
15:45:01 INFO - #####
15:45:01 INFO - ##### Running build-shell step.
15:45:01 INFO - #####
15:45:01 INFO - Running main action method: build_shell
15:45:01 INFO - Running command: ['mock_mozilla', '-r', u'mozilla-centos6-x86_64', '-q', '--cwd', '/builds/slave/l64-br-haz_m-in_dep-0000000000/build/obj-opt-js', '--unpriv', '--shell', '/usr/bin/env "LESSOPEN=|/usr/bin/lesspipe.sh %s" TMOUT=86400 CVS_RSH=ssh LOGNAME=cltbld USER=cltbld PATH=/tools/python27/bin:/builds/slave/l64-br-haz_m-in_dep-0000000000/build/gcc/bin:/usr/local/bin:/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cltbld/bin LD_LIBRARY_PATH=/builds/slave/l64-br-haz_m-in_dep-0000000000/build/sixgill/usr/lib64 LANG=en_US.UTF-8 CCACHE_HASHDIR= TERM=linux SHELL=/bin/bash SHLVL=1 G_BROKEN_FILENAMES=1 HISTSIZE=1000 HG_SHARE_BASE_DIR=/builds/hg-shared TINDERBOX_OUTPUT=1 MAIL=/var/spool/mail/cltbld HOSTNAME=bld-linux64-spot-160.build.releng.use1.mozilla.com HISTCONTROL=ignoredups PROPERTIES_FILE=/builds/slave/l64-br-haz_m-in_dep-0000000000/buildprops.json MOZ_CRASHREPORTER_NO_REPORT=1 make -j 4 -s'] in /builds/slave/l64-br-haz_m-in_dep-0000000000/build/obj-opt-js
15:45:01 INFO - Copy/paste: mock_mozilla -r mozilla-centos6-x86_64 -q --cwd /builds/slave/l64-br-haz_m-in_dep-0000000000/build/obj-opt-js --unpriv --shell "/usr/bin/env \"LESSOPEN=|/usr/bin/lesspipe.sh %s\" TMOUT=86400 CVS_RSH=ssh LOGNAME=cltbld USER=cltbld PATH=/tools/python27/bin:/builds/slave/l64-br-haz_m-in_dep-0000000000/build/gcc/bin:/usr/local/bin:/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cltbld/bin LD_LIBRARY_PATH=/builds/slave/l64-br-haz_m-in_dep-0000000000/build/sixgill/usr/lib64 LANG=en_US.UTF-8 CCACHE_HASHDIR= TERM=linux SHELL=/bin/bash SHLVL=1 G_BROKEN_FILENAMES=1 HISTSIZE=1000 HG_SHARE_BASE_DIR=/builds/hg-shared TINDERBOX_OUTPUT=1 MAIL=/var/spool/mail/cltbld HOSTNAME=bld-linux64-spot-160.build.releng.use1.mozilla.com HISTCONTROL=ignoredups PROPERTIES_FILE=/builds/slave/l64-br-haz_m-in_dep-0000000000/buildprops.json MOZ_CRASHREPORTER_NO_REPORT=1 make -j 4 -s"
15:45:01 INFO - From dist/idl: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - From dist/bin: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - From dist/public: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - From dist/include: Kept 0 existing; Added/updated 119; Removed 0 files and 0 directories.
15:45:01 INFO - From dist/private: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - From dist/sdk: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - From dist/xpi-stage: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - From _tests: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
15:45:01 INFO - host_nsinstall.o
15:45:01 INFO - host_pathsub.o
15:45:02 INFO - nsinstall_real
15:45:02 INFO - /builds/slave/l64-br-haz_m-in_dep-0000000000/build/gcc/bin/c++ -E -o self-hosting-preprocessed.pp -DAB_CD= -DHAVE_64BIT_BUILD=1 -DXP_UNIX=1 -DHAVE_GETC_UNLOCKED=1 -DHAVE_X11_XKBLIB_H=1 -DJS_PUNBOX64=1 -DNO_NSPR_10_SUPPORT=1 -DHAVE_LIBM=1 -DHAVE_POSIX_FALLOCATE=1 -DDLL_SUFFIX=".so" -DHAVE_ACOSH=1 -DHAVE_GNU_LIBC_VERSION_H=1 -DHAVE___CXA_DEMANGLE=1 -DHAVE_THREAD_TLS_KEYWORD=1 -DJS_CODEGEN_X64=1 -DMALLOC_H=<malloc.h> -DHAVE_LANGINFO_CODESET=1 -DSTDC_HEADERS=1 -DJS_CPU_X64=1 -DHAVE_SYS_CDEFS_H=1 -DTRIMMED=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_MEMORY_H=1 -DHAVE_DLOPEN=1 -D_REENTRANT=1 -DHAVE_MALLOC_H=1 -DMOZ_DLL_SUFFIX=".so" -DMOZ_MEMORY=1 -DMOZILLA_UAVERSION="" -DHAVE_SYS_BITYPES_H=1 -DHAVE_POSIX_FADVISE=1 -DHAVE_CBRT=1 -DHAVE_RES_NINIT=1 -DHAVE_CPP_DYNAMIC_CAST_TO_VOID_PTR=1 -DHAVE_TM_ZONE_TM_GMTOFF=1 -DVA_COPY=va_copy -DJS_HAVE_ENDIAN_H=1 -DENABLE_BINARYDATA=1 -DHAVE_LOCALECONV=1 -DMOZILLA_VERSION_U= -DHAVE_CPUID_H=1 -DHAVE_SYS_QUOTA_H=1 -DMOZ_DEBUG_SYMBOLS=1 -DHAVE_ENDIAN_H=1 -DMOZJS_MAJOR_VERSION= -DHAVE_SETLOCALE=1 -DNS_ATTR_MALLOC=__attribute__((malloc)) -DHAVE_SYS_STATFS_H=1 -DDLL_PREFIX="lib" -DMOZILLA_VERSION="" -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_MBRTOWC=1 -DNIGHTLY_BUILD=1 -DHAVE_UNISTD_H=1 -DMOZ_MEMORY_LINUX=1 -DJS_STANDALONE=1 -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE=1 -DHAVE_I18N_LC_MESSAGES=1 -DD_INO=d_ino -DJS_TRACE_LOGGING=1 -DHAVE_ASINH=1 -DHAVE_GETOPT_H=1 -DHAVE_GMTIME_R=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DHAVE_SYS_VFS_H=1 -DENABLE_SHARED_ARRAY_BUFFER=1 -DHAVE_WCRTOMB=1 -DHAVE_SYS_MOUNT_H=1 -DNS_WARN_UNUSED_RESULT=__attribute__((warn_unused_result)) -DCPP_THROW_NEW=throw() -DHAVE_ATANH=1 -DHAVE_SSIZE_T=1 -DHAVE_DIRENT_H=1 -DHAVE_NL_TYPES_H=1 -DFFI_BUILDING=1 -DEXPORT_JS_API=1 -DJS_HAS_CTYPES=1 -DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_VA_COPY=1 -DNDEBUG=1 -DMOZ_GLUE_IN_PROGRAM=1 -DMOZJS_MINOR_VERSION= -DHAVE_LOG2=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_TRUNC=1 -DMOZ_UPDATE_CHANNEL=default -DHAVE_EXPM1=1 -DHAVE_LOG1P=1 -DEDITLINE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_VA_LIST_AS_ARRAY=1 self-hosting-cpp-input.cpp
15:45:02 INFO - libnspr.a.desc
15:45:02 INFO - libzlib.a.desc
15:45:02 INFO - Compression.o
15:45:02 INFO - Decimal.o
15:45:02 INFO - Making all in include
15:45:02 INFO - Making all in testsuite
15:45:02 INFO - Making all in man
15:45:02 INFO - jemalloc.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/types.lo -MD -MP -MF src/.deps/types.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/types.c -fPIC -DPIC -o src/types.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/prep_cif.lo -MD -MP -MF src/.deps/prep_cif.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/prep_cif.c -fPIC -DPIC -o src/prep_cif.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/raw_api.lo -MD -MP -MF src/.deps/raw_api.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/raw_api.c -fPIC -DPIC -o src/raw_api.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/java_raw_api.lo -MD -MP -MF src/.deps/java_raw_api.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/java_raw_api.c -fPIC -DPIC -o src/java_raw_api.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/closures.lo -MD -MP -MF src/.deps/closures.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/closures.c -fPIC -DPIC -o src/closures.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/x86/ffi64.lo -MD -MP -MF src/x86/.deps/ffi64.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/x86/ffi64.c -fPIC -DPIC -o src/x86/ffi64.o
15:45:02 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -MT src/x86/unix64.lo -MD -MP -MF src/x86/.deps/unix64.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/x86/unix64.S -fPIC -DPIC -o src/x86/unix64.o
15:45:03 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -O3 -fomit-frame-pointer -fstrict-aliasing -ffast-math -march=core2 -Wall -fexceptions -MT src/x86/ffi.lo -MD -MP -MF src/x86/.deps/ffi.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/x86/ffi.c -fPIC -DPIC -o src/x86/ffi.o
15:45:03 INFO - libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -I. -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src -MT src/x86/sysv.lo -MD -MP -MF src/x86/.deps/sysv.Tpo -c /builds/slave/l64-br-haz_m-in_dep-0000000000/build/source/js/src/ctypes/libffi/src/x86/sysv.S -fPIC -DPIC -o src/x86/sysv.o
15:45:03 INFO - Unified_cpp_mfbt0.o
15:45:03 INFO - libtool: link: ar cru .libs/libffi_convenience.a src/prep_cif.o src/types.o src/raw_api.o src/java_raw_api.o src/closures.o src/x86/ffi64.o src/x86/unix64.o src/x86/ffi.o src/x86/sysv.o
15:45:03 INFO - libtool: link: ranlib .libs/libffi_convenience.a
15:45:03 INFO - libtool: link: ( cd ".libs" && rm -f "libffi_convenience.la" && ln -s "../libffi_convenience.la" "libffi_convenience.la" )
15:45:03 INFO - libtool: link: ar cru .libs/libffi.a src/prep_cif.o src/types.o src/raw_api.o src/java_raw_api.o src/closures.o src/x86/ffi64.o src/x86/unix64.o src/x86/ffi.o src/x86/sysv.o
15:45:03 INFO - libtool: link: ranlib .libs/libffi.a
15:45:03 INFO - libtool: link: ( cd ".libs" && rm -f "libffi.la" && ln -s "../libffi.la" "libffi.la" )
15:45:03 INFO - libffi.a.desc
15:45:03 INFO - Unified_c_js_src_editline0.o
15:45:04 INFO - host_jskwgen.o
15:45:04 INFO - host_jskwgen
15:45:05 INFO - libeditline.a.desc
15:45:05 INFO - make[3]: execvp: ./host_jskwgen: Permission denied
15:45:05 ERROR - make[3]: *** [/builds/slave/l64-br-haz_m-in_dep-0000000000/build/obj-opt-js/js/src/jsautokw.h] Error 127
15:45:05 ERROR - make[2]: *** [js/src/target] Error 2
15:45:05 INFO - make[2]: *** Waiting for unfinished jobs....
15:45:05 INFO - libjemalloc.a.desc
15:45:06 INFO - libmfbt.a.desc
15:45:06 ERROR - make[1]: *** [compile] Error 2
15:45:06 INFO - make: *** [default] Error 2
15:45:06 ERROR - Return code: 2
15:45:06 FATAL - "Build failed, can't continue."
15:45:06 FATAL - Running post_fatal callback...
15:45:06 FATAL - Exiting 2
program finished with exit code 2
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Flags: needinfo?(sphink)
Summary: Intermittent hazard build failure with "make[3]: *** [jsautokw.h] Error 127" → Intermittent hazard build failure with "make[3]: *** [/builds/slave/l64-br-haz_m-in_dep-0000000000/build/obj-opt-js/js/src/jsautokw.h] Error 127"
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
See Also: → bug 1146738
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sphink)
Resolution: --- → DUPLICATE
Duplicate of bug: 1146738
You need to log in before you can comment on or make changes to this bug.