[Flame][Video]No image will show after user goes to landscape mode to resume playing a video.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Video
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Norry.L.F(Leave from Mozilla), Assigned: jerry)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8582983 [details]
video_1439.mp4

[1.Description]:
[Flame][v2.2][Video] No image will show if  user pause a video by invoking a menu and then go to landscape mode to resume playing this video. 
Attachment:logcat_1439.txt & video_1439.mp4
Found time: 14:39

[2.Testing Steps]: 
1.Open video app and play a video.
2.Bring up the menu by tapping "..." .
3.Rotate screen to landscape.
4.Close menu by tapping "Cancel".
5.Tap the play button

[3.Expected Result]: 
 The image and audio should sync after user resume  playing a video in  landscape mode.

[4.Actual Result]: 
5.There is no  image.

[5.Reproduction build]: 
Flame 2.2:(Affected)
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041652
Firmware Date          Tue Mar 24 04:17:03 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0:(unaffected)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8582984 [details]
logcat_1439.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.1S: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: unaffected → ---

Updated

3 years ago
blocking-b2g: --- → 2.2?

Comment 2

3 years ago
Marking it regression. Based on the flags and tests set, it looks like this works fine in 2.1 and 3.0 and broken in 2.2.

David/Russ,

Can one of you look into this. 

Thanks
Hema
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(rnicoletti)
Flags: needinfo?(dflanagan)
Keywords: regression
I could check this bug, but I would like a regression window first. Maybe it's related to gfx.
Assignee: nobody → hshih
Keywords: regressionwindow-wanted
QA Contact: ktucker
I could easily reproduce this on the reporters build. 

There is no video after following the STR in Comment 0.

Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150326002504
Gaia: e59ac067a1d22b7a72cbebc892ec652723f2a557
Gecko: 04b4b9d1faae
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----------------------------------

I could not reproduce this issue after several attempts on the latest Flame 2.2

The video plays as expected without issue.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150324002504
Gaia: 014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gecko: 7a9f2a248e57
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Closing this as worksforme. Please reopen this issue if it occurs again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
Correction. Had the variables reversed.

I could easily reproduce this on the reporters build. 

There is no video after following the STR in Comment 0.

Device: Flame 2.2(Full Flash)(KK)(319mb)
BuildID: 20150324002504
Gaia: 014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gecko: 7a9f2a248e57
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----------------------------------

I could not reproduce this issue after several attempts on the latest Flame 2.2

The video plays as expected without issue.

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150326002504
Gaia: e59ac067a1d22b7a72cbebc892ec652723f2a557
Gecko: 04b4b9d1faae
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Closing this as worksforme. Please reopen this issue if it occurs again.
Clearing NI, I also could not reproduce using the latest 2.2 build on Flame.
Flags: needinfo?(rnicoletti)
Resolution: WORKSFORME → FIXED
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S9 (3apr)
(Assignee)

Updated

3 years ago
Flags: needinfo?(dflanagan)
This issue has been successfully verified on Flame 2.2
Reproducing rate: 0/5

Flame 2.2:
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.