Closed Bug 1147326 Opened 5 years ago Closed 5 years ago

[Flame[Settings]User can't input SIM2's PIN1 code and SIM2 card will be recognized directly after tap "OK" although you did not inputted SIM2 PIN1 if two SIM cards have same PIN1 codes.

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1147944
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: lixia, Unassigned)

References

Details

Attachments

(4 files)

[1.Description]:
[Flame][v3.0][Settings]User can't input SIM2 PIN1 code after inputting SIM1 code because SIM1 PIN1 code is filled in the input box of SIM2 PIN1 code. And SIM2 card will be recognized directly after tap "OK" although you did not inputted SIM2 PIN1 when two SIM cards have same PIN1 codes.

Found time:16:04
Attach:same_PIN1.mp4 ,logcat_same_PIN1.txt,   logcat_different_PIN1_1604.txt and different_PIN1.mp4.

[2.Testing Steps]: 
1.Insert two SIM cards with PIN1 codes.
2.Power on device for prompting user to input PIN1 codes.
3.Input correct SIM1 PIN1 code.
4.Try to input SIM2 PIN1 code,but fail,then tap "OK".

[3.Expected Result]: 
3&4.User can input SIM2's PIN1 code after inputting SIM1's code.

[4.Actual Result]: 
3.The SIM1's PIN code will fill in the input box of SIM2's PIN code,and you can't edit the input box never.
4-1.If two SIM cards have different PIN codes,the prompt "The PIN was incorrect" will pop up.
4-2.If two SIM cards have same PIN codes,SIM2 will be recognized although you did not inputted SIM2‘s PIN.

[5.Reproduction build]: 
Device: Flame 2.2 (Unaffected)
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041652
Firmware Date          Tue Mar 24 04:17:03 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (Affected)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
See Also: → 1020916
Summary: [Flame[Settings]Numbers entered in SIM1's PIN1 code input box is transfered to SIM2's PIN1 code input box. → [Flame[Settings]Numbers entered in SIM1's PIN1 code input box is transfered to SIM2's PIN1 code input box, and SIM2 card will be recognized directly after tap "OK" although you did not inputted SIM2 PIN1 if two SIM cards have same PIN1 codes.
Attached video different_PIN1.mp4
Attached video same_PIN1.mp4
I can repro this bug on today's Flame v2.2 build(full flash 319mb).

Device: Flame 2.2 build(Unaffected)
Build ID               20150324162501
Gaia Revision          7024dd4c7a7c3616dc8f9f908759f00abc0deddd
Gaia Date              2015-03-24 14:01:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/79a8767e838e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.203451
Firmware Date          Tue Mar 24 20:35:02 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 build(Affected)
Build ID               20150325002503
Gaia Revision          aeee2a54caa8ffb875b96264b61d742b70689f22
Gaia Date              2015-03-25 03:57:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/556aca3e50ac
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.041148
Firmware Date          Wed Mar 25 04:11:58 EDT 2015
Bootloader             L1TC000118D0
Summary: [Flame[Settings]Numbers entered in SIM1's PIN1 code input box is transfered to SIM2's PIN1 code input box, and SIM2 card will be recognized directly after tap "OK" although you did not inputted SIM2 PIN1 if two SIM cards have same PIN1 codes. → [Flame[Settings]User can't input SIM2's PIN1 code and SIM2 card will be recognized directly after tap "OK" although you did not inputted SIM2 PIN1 if two SIM cards have same PIN1 codes.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147944
You need to log in before you can comment on or make changes to this bug.